Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1321799
| From | Gustavo Padovan <gustavo@padovan.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 00/11] sync framework de-staging: part 1 - clean up |
| Date | 2016-01-29 15:50 +0100 |
| Message-ID | <qWix3-4ym-1@gated-at.bofh.it> (permalink) |
| References | <qTn0d-5nD-9@gated-at.bofh.it> <qUNvl-37P-41@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi, 2016-01-25 Maarten Lankhorst <maarten.lankhorst@linux.intel.com>: > Hey, > > Op 21-01-16 om 13:49 schreef Gustavo Padovan: > > From: Gustavo Padovan <gustavo.padovan@collabora.co.uk> > > > > Hi, > > > > The following patches are some clean ups on the sync framework before > > we start the actual de-staging. The main changes here are the move of > > SW_SYNC_USER to debugfs. Removal of struct sync_pt in favor of direct > > use of struct fence. And the rename of sync_fence to sync_file, a name > > to better reflect what it is for, a struct that connects struct fence(s) > > to a file. > > > > Please review. Thanks. > > > > Gustavo Padovan (11): > > staging/android: fix sync framework documentation > > staging/android: sync: remove interfaces that are not used > > staging/android: remove not used sync_timeline ops > > staging/android: create a 'sync' dir for debugfs information > > staging/android: move SW_SYNC_USER to a debugfs file > > staging/android: rename sync_fence to sync_file > > staging/android: rename 'sync_pt' to 'fence' in struct sync_fence_cb > > staging/android: remove struct sync_pt > > staging/android: remove unused var from sync_timeline_signal() > > staging/android: remove pointless sync_timeline_signal at destroy > > phase > > staging/android: remove sync_fence_create_dma() > > > For whole series: > Reviewed-by: Maarten Lankhorst <maarten.lankhorst@linux.intel.com> > > Renaming sync_fence to sync_file makes sense, it should hopefully reduce confusion. Poke. What is missing for this to go upstream? Do I need more review here? Thanks. Gustavo
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
Re: [PATCH 00/11] sync framework de-staging: part 1 - clean up Gustavo Padovan <gustavo@padovan.org> - 2016-01-29 15:50 +0100 Re: [PATCH 00/11] sync framework de-staging: part 1 - clean up Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2016-01-29 17:20 +0100
csiph-web