Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1311796 > unrolled thread
| Started by | Rasmus Villemoes <linux@rasmusvillemoes.dk> |
|---|---|
| First post | 2016-01-18 21:40 +0100 |
| Last post | 2016-01-18 21:40 +0100 |
| Articles | 1 — 1 participant |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH v2 01/11] lib/vsprintf: introduce put_one_char() for 3 line idiom Rasmus Villemoes <linux@rasmusvillemoes.dk> - 2016-01-18 21:40 +0100
| From | Rasmus Villemoes <linux@rasmusvillemoes.dk> |
|---|---|
| Date | 2016-01-18 21:40 +0100 |
| Subject | Re: [PATCH v2 01/11] lib/vsprintf: introduce put_one_char() for 3 line idiom |
| Message-ID | <qSoKK-5M1-9@gated-at.bofh.it> |
On Thu, Jan 14 2016, Andy Shevchenko <andriy.shevchenko@linux.intel.com> wrote: > There is an idiom used widely in the code > > if (buf < end) > *buf = c; > ++buf; > > Introduce put_one_char() helper as implementation of this idiom. > I suppose it does make the code a little more readable, but the current idiom isn't that bad. Does it affect the generated code, and if so, does it become smaller/larger, faster/slower? Rasmus
Back to top | Article view | linux.kernel
csiph-web