Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1311796
| From | Rasmus Villemoes <linux@rasmusvillemoes.dk> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 01/11] lib/vsprintf: introduce put_one_char() for 3 line idiom |
| Date | 2016-01-18 21:40 +0100 |
| Message-ID | <qSoKK-5M1-9@gated-at.bofh.it> (permalink) |
| References | <qQYz0-5b5-1@gated-at.bofh.it> <qQYz1-5b5-49@gated-at.bofh.it> |
| Organization | D03 |
On Thu, Jan 14 2016, Andy Shevchenko <andriy.shevchenko@linux.intel.com> wrote: > There is an idiom used widely in the code > > if (buf < end) > *buf = c; > ++buf; > > Introduce put_one_char() helper as implementation of this idiom. > I suppose it does make the code a little more readable, but the current idiom isn't that bad. Does it affect the generated code, and if so, does it become smaller/larger, faster/slower? Rasmus
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [PATCH v2 01/11] lib/vsprintf: introduce put_one_char() for 3 line idiom Rasmus Villemoes <linux@rasmusvillemoes.dk> - 2016-01-18 21:40 +0100
csiph-web