Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1307951 > unrolled thread
| Started by | Jacob Pan <jacob.jun.pan@linux.intel.com> |
|---|---|
| First post | 2016-01-13 02:20 +0100 |
| Last post | 2016-01-13 02:20 +0100 |
| Articles | 1 — 1 participant |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH 1/2] x86/msr: add on cpu read/modify/write function Jacob Pan <jacob.jun.pan@linux.intel.com> - 2016-01-13 02:20 +0100
| From | Jacob Pan <jacob.jun.pan@linux.intel.com> |
|---|---|
| Date | 2016-01-13 02:20 +0100 |
| Subject | Re: [PATCH 1/2] x86/msr: add on cpu read/modify/write function |
| Message-ID | <qQigp-HG-1@gated-at.bofh.it> |
On Sun, 20 Dec 2015 14:28:48 +0100 (CET)
Thomas Gleixner <tglx@linutronix.de> wrote:
> So this is a copy of the above !SMP inline. What's wrong with
> providing:
>
> int rmwmsrl_safe(msr_no, clear_mask, set_mask)
>
> in x86/lib/msr.c and make the !SMP variant of rdmsrl_safe_on_cpu()
> and that variant for the SMP case a simple wrapper around it?
>
> static void remote_rmwmsrl_safe(void *info)
> {
> struct msr_action *ma = info;
>
> return rmwmsrl_safe(ma->msr, ma->clear_mask, ma->set_mask);
> }
>
> No gotos, no pointless code duplication. Just simple.
much better, just sent new code in v2. Sorry for the delay.
Thanks
Back to top | Article view | linux.kernel
csiph-web