Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1299936 > unrolled thread

[PATCH 1/7] char: xillybus: use to_delayed_work

Started byGeliang Tang <geliangtang@163.com>
First post2016-01-01 16:10 +0100
Last post2016-01-01 21:10 +0100
Articles 9 — 4 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH 1/7] char: xillybus: use to_delayed_work Geliang Tang <geliangtang@163.com> - 2016-01-01 16:10 +0100
    [PATCH 6/7] power: generic-adc-battery: use to_delayed_work Geliang Tang <geliangtang@163.com> - 2016-01-01 16:10 +0100
    [PATCH 3/7] input: touchscreen: use to_delayed_work Geliang Tang <geliangtang@163.com> - 2016-01-01 16:10 +0100
      Re: [PATCH 3/7] input: touchscreen: use to_delayed_work Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2016-01-03 06:10 +0100
    [PATCH 7/7] mvsas: use to_delayed_work Geliang Tang <geliangtang@163.com> - 2016-01-01 16:10 +0100
    [PATCH 2/7] edac: i5100_edac: use to_delayed_work Geliang Tang <geliangtang@163.com> - 2016-01-01 16:10 +0100
      Re: [PATCH 2/7] edac: i5100_edac: use to_delayed_work Borislav Petkov <bp@alien8.de> - 2016-01-01 18:40 +0100
    [PATCH 4/7] mmc: sh_mmcif: use to_delayed_work Geliang Tang <geliangtang@163.com> - 2016-01-01 16:10 +0100
    Re: [PATCH 1/7] char: xillybus: use to_delayed_work Eli Billauer <eli.billauer@gmail.com> - 2016-01-01 21:10 +0100

#1299936 — [PATCH 1/7] char: xillybus: use to_delayed_work

FromGeliang Tang <geliangtang@163.com>
Date2016-01-01 16:10 +0100
Subject[PATCH 1/7] char: xillybus: use to_delayed_work
Message-ID<qM9v4-42d-3@gated-at.bofh.it>
Use to_delayed_work() instead of open-coding it.

Signed-off-by: Geliang Tang <geliangtang@163.com>
---
 drivers/char/xillybus/xillybus_core.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/drivers/char/xillybus/xillybus_core.c b/drivers/char/xillybus/xillybus_core.c
index 77d6c12..3bd36e0 100644
--- a/drivers/char/xillybus/xillybus_core.c
+++ b/drivers/char/xillybus/xillybus_core.c
@@ -1164,8 +1164,7 @@ static int xillybus_flush(struct file *filp, fl_owner_t id)
 
 static void xillybus_autoflush(struct work_struct *work)
 {
-	struct delayed_work *workitem = container_of(
-		work, struct delayed_work, work);
+	struct delayed_work *workitem = to_delayed_work(work);
 	struct xilly_channel *channel = container_of(
 		workitem, struct xilly_channel, rd_workitem);
 	int rc;
-- 
2.5.0


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1299937 — [PATCH 6/7] power: generic-adc-battery: use to_delayed_work

FromGeliang Tang <geliangtang@163.com>
Date2016-01-01 16:10 +0100
Subject[PATCH 6/7] power: generic-adc-battery: use to_delayed_work
Message-ID<qM9v4-42d-7@gated-at.bofh.it>
In reply to#1299936
Use to_delayed_work() instead of open-coding it.

Signed-off-by: Geliang Tang <geliangtang@163.com>
---
 drivers/power/generic-adc-battery.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/power/generic-adc-battery.c b/drivers/power/generic-adc-battery.c
index fedc581..edb36bf 100644
--- a/drivers/power/generic-adc-battery.c
+++ b/drivers/power/generic-adc-battery.c
@@ -206,7 +206,7 @@ static void gab_work(struct work_struct *work)
 	bool is_plugged;
 	int status;
 
-	delayed_work = container_of(work, struct delayed_work, work);
+	delayed_work = to_delayed_work(work);
 	adc_bat = container_of(delayed_work, struct gab, bat_work);
 	pdata = adc_bat->pdata;
 	status = adc_bat->status;
-- 
2.5.0


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1299938 — [PATCH 3/7] input: touchscreen: use to_delayed_work

FromGeliang Tang <geliangtang@163.com>
Date2016-01-01 16:10 +0100
Subject[PATCH 3/7] input: touchscreen: use to_delayed_work
Message-ID<qM9v4-42d-13@gated-at.bofh.it>
In reply to#1299936
Use to_delayed_work() instead of open-coding it.

Signed-off-by: Geliang Tang <geliangtang@163.com>
---
 drivers/input/touchscreen/pcap_ts.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/input/touchscreen/pcap_ts.c b/drivers/input/touchscreen/pcap_ts.c
index 23a354a..0e3fc41 100644
--- a/drivers/input/touchscreen/pcap_ts.c
+++ b/drivers/input/touchscreen/pcap_ts.c
@@ -87,7 +87,7 @@ static void pcap_ts_read_xy(void *data, u16 res[2])
 
 static void pcap_ts_work(struct work_struct *work)
 {
-	struct delayed_work *dw = container_of(work, struct delayed_work, work);
+	struct delayed_work *dw = to_delayed_work(work);
 	struct pcap_ts *pcap_ts = container_of(dw, struct pcap_ts, work);
 	u8 ch[2];
 
-- 
2.5.0


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1300176 — Re: [PATCH 3/7] input: touchscreen: use to_delayed_work

FromDmitry Torokhov <dmitry.torokhov@gmail.com>
Date2016-01-03 06:10 +0100
SubjectRe: [PATCH 3/7] input: touchscreen: use to_delayed_work
Message-ID<qMJ5w-10D-5@gated-at.bofh.it>
In reply to#1299938
On Fri, Jan 01, 2016 at 10:59:08PM +0800, Geliang Tang wrote:
> Use to_delayed_work() instead of open-coding it.
> 
> Signed-off-by: Geliang Tang <geliangtang@163.com>

Applied, thank you.

> ---
>  drivers/input/touchscreen/pcap_ts.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/input/touchscreen/pcap_ts.c b/drivers/input/touchscreen/pcap_ts.c
> index 23a354a..0e3fc41 100644
> --- a/drivers/input/touchscreen/pcap_ts.c
> +++ b/drivers/input/touchscreen/pcap_ts.c
> @@ -87,7 +87,7 @@ static void pcap_ts_read_xy(void *data, u16 res[2])
>  
>  static void pcap_ts_work(struct work_struct *work)
>  {
> -	struct delayed_work *dw = container_of(work, struct delayed_work, work);
> +	struct delayed_work *dw = to_delayed_work(work);
>  	struct pcap_ts *pcap_ts = container_of(dw, struct pcap_ts, work);
>  	u8 ch[2];
>  
> -- 
> 2.5.0
> 
> 

-- 
Dmitry
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1299939 — [PATCH 7/7] mvsas: use to_delayed_work

FromGeliang Tang <geliangtang@163.com>
Date2016-01-01 16:10 +0100
Subject[PATCH 7/7] mvsas: use to_delayed_work
Message-ID<qM9v4-42d-17@gated-at.bofh.it>
In reply to#1299936
Use to_delayed_work() instead of open-coding it.

Signed-off-by: Geliang Tang <geliangtang@163.com>
---
 drivers/scsi/mvsas/mv_sas.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/scsi/mvsas/mv_sas.c b/drivers/scsi/mvsas/mv_sas.c
index e712fe7..78bf557 100644
--- a/drivers/scsi/mvsas/mv_sas.c
+++ b/drivers/scsi/mvsas/mv_sas.c
@@ -1887,7 +1887,7 @@ static void mvs_phy_disconnected(struct mvs_phy *phy)
 
 static void mvs_work_queue(struct work_struct *work)
 {
-	struct delayed_work *dw = container_of(work, struct delayed_work, work);
+	struct delayed_work *dw = to_delayed_work(work);
 	struct mvs_wq *mwq = container_of(dw, struct mvs_wq, work_q);
 	struct mvs_info *mvi = mwq->mvi;
 	unsigned long flags;
-- 
2.5.0


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1299940 — [PATCH 2/7] edac: i5100_edac: use to_delayed_work

FromGeliang Tang <geliangtang@163.com>
Date2016-01-01 16:10 +0100
Subject[PATCH 2/7] edac: i5100_edac: use to_delayed_work
Message-ID<qM9v4-42d-15@gated-at.bofh.it>
In reply to#1299936
Use to_delayed_work() instead of open-coding it.

Signed-off-by: Geliang Tang <geliangtang@163.com>
---
 drivers/edac/i5100_edac.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/drivers/edac/i5100_edac.c b/drivers/edac/i5100_edac.c
index 4091777..c655162 100644
--- a/drivers/edac/i5100_edac.c
+++ b/drivers/edac/i5100_edac.c
@@ -575,9 +575,7 @@ static void i5100_check_error(struct mem_ctl_info *mci)
 
 static void i5100_refresh_scrubbing(struct work_struct *work)
 {
-	struct delayed_work *i5100_scrubbing = container_of(work,
-							    struct delayed_work,
-							    work);
+	struct delayed_work *i5100_scrubbing = to_delayed_work(work);
 	struct i5100_priv *priv = container_of(i5100_scrubbing,
 					       struct i5100_priv,
 					       i5100_scrubbing);
-- 
2.5.0


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1299960 — Re: [PATCH 2/7] edac: i5100_edac: use to_delayed_work

FromBorislav Petkov <bp@alien8.de>
Date2016-01-01 18:40 +0100
SubjectRe: [PATCH 2/7] edac: i5100_edac: use to_delayed_work
Message-ID<qMbQd-5ph-3@gated-at.bofh.it>
In reply to#1299940
On Fri, Jan 01, 2016 at 10:59:07PM +0800, Geliang Tang wrote:
> Use to_delayed_work() instead of open-coding it.
> 
> Signed-off-by: Geliang Tang <geliangtang@163.com>
> ---
>  drivers/edac/i5100_edac.c | 4 +---
>  1 file changed, 1 insertion(+), 3 deletions(-)
> 
> diff --git a/drivers/edac/i5100_edac.c b/drivers/edac/i5100_edac.c
> index 4091777..c655162 100644
> --- a/drivers/edac/i5100_edac.c
> +++ b/drivers/edac/i5100_edac.c
> @@ -575,9 +575,7 @@ static void i5100_check_error(struct mem_ctl_info *mci)
>  
>  static void i5100_refresh_scrubbing(struct work_struct *work)
>  {
> -	struct delayed_work *i5100_scrubbing = container_of(work,
> -							    struct delayed_work,
> -							    work);
> +	struct delayed_work *i5100_scrubbing = to_delayed_work(work);
>  	struct i5100_priv *priv = container_of(i5100_scrubbing,
>  					       struct i5100_priv,
>  					       i5100_scrubbing);
> -- 

Applied, thanks.

-- 
Regards/Gruss,
    Boris.

ECO tip #101: Trim your mails when you reply.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1299941 — [PATCH 4/7] mmc: sh_mmcif: use to_delayed_work

FromGeliang Tang <geliangtang@163.com>
Date2016-01-01 16:10 +0100
Subject[PATCH 4/7] mmc: sh_mmcif: use to_delayed_work
Message-ID<qM9v4-42d-19@gated-at.bofh.it>
In reply to#1299936
Use to_delayed_work() instead of open-coding it.

Signed-off-by: Geliang Tang <geliangtang@163.com>
---
 drivers/mmc/host/sh_mmcif.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/mmc/host/sh_mmcif.c b/drivers/mmc/host/sh_mmcif.c
index 1ca8a13..e0c076a 100644
--- a/drivers/mmc/host/sh_mmcif.c
+++ b/drivers/mmc/host/sh_mmcif.c
@@ -1395,7 +1395,7 @@ static irqreturn_t sh_mmcif_intr(int irq, void *dev_id)
 
 static void sh_mmcif_timeout_work(struct work_struct *work)
 {
-	struct delayed_work *d = container_of(work, struct delayed_work, work);
+	struct delayed_work *d = to_delayed_work(work);
 	struct sh_mmcif_host *host = container_of(d, struct sh_mmcif_host, timeout_work);
 	struct mmc_request *mrq = host->mrq;
 	struct device *dev = sh_mmcif_host_to_dev(host);
-- 
2.5.0


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1299980

FromEli Billauer <eli.billauer@gmail.com>
Date2016-01-01 21:10 +0100
Message-ID<qMebo-71o-5@gated-at.bofh.it>
In reply to#1299936
Hello,

It's fine with me, but this patch needs to go to the char and misc 
drivers maintainers (i.e. Arnd Bergmann and Greg Kroah-Hartman). I don't 
have a repository of my own.

Thanks,
    Eli

Acked-by: Eli Billauer <eli.billauer@gmail.com>

On 01/01/16 16:59, Geliang Tang wrote:
> Use to_delayed_work() instead of open-coding it.
>
> Signed-off-by: Geliang Tang<geliangtang@163.com>
> ---
>   drivers/char/xillybus/xillybus_core.c | 3 +--
>   1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/char/xillybus/xillybus_core.c b/drivers/char/xillybus/xillybus_core.c
> index 77d6c12..3bd36e0 100644
> --- a/drivers/char/xillybus/xillybus_core.c
> +++ b/drivers/char/xillybus/xillybus_core.c
> @@ -1164,8 +1164,7 @@ static int xillybus_flush(struct file *filp, fl_owner_t id)
>
>   static void xillybus_autoflush(struct work_struct *work)
>   {
> -	struct delayed_work *workitem = container_of(
> -		work, struct delayed_work, work);
> +	struct delayed_work *workitem = to_delayed_work(work);
>   	struct xilly_channel *channel = container_of(
>   		workitem, struct xilly_channel, rd_workitem);
>   	int rc;
>    

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web