Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1299960

Re: [PATCH 2/7] edac: i5100_edac: use to_delayed_work

From Borislav Petkov <bp@alien8.de>
Newsgroups linux.kernel
Subject Re: [PATCH 2/7] edac: i5100_edac: use to_delayed_work
Date 2016-01-01 18:40 +0100
Message-ID <qMbQd-5ph-3@gated-at.bofh.it> (permalink)
References <qM9v4-42d-3@gated-at.bofh.it> <qM9v4-42d-15@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, Jan 01, 2016 at 10:59:07PM +0800, Geliang Tang wrote:
> Use to_delayed_work() instead of open-coding it.
> 
> Signed-off-by: Geliang Tang <geliangtang@163.com>
> ---
>  drivers/edac/i5100_edac.c | 4 +---
>  1 file changed, 1 insertion(+), 3 deletions(-)
> 
> diff --git a/drivers/edac/i5100_edac.c b/drivers/edac/i5100_edac.c
> index 4091777..c655162 100644
> --- a/drivers/edac/i5100_edac.c
> +++ b/drivers/edac/i5100_edac.c
> @@ -575,9 +575,7 @@ static void i5100_check_error(struct mem_ctl_info *mci)
>  
>  static void i5100_refresh_scrubbing(struct work_struct *work)
>  {
> -	struct delayed_work *i5100_scrubbing = container_of(work,
> -							    struct delayed_work,
> -							    work);
> +	struct delayed_work *i5100_scrubbing = to_delayed_work(work);
>  	struct i5100_priv *priv = container_of(i5100_scrubbing,
>  					       struct i5100_priv,
>  					       i5100_scrubbing);
> -- 

Applied, thanks.

-- 
Regards/Gruss,
    Boris.

ECO tip #101: Trim your mails when you reply.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 1/7] char: xillybus: use to_delayed_work Geliang Tang <geliangtang@163.com> - 2016-01-01 16:10 +0100
  [PATCH 6/7] power: generic-adc-battery: use to_delayed_work Geliang Tang <geliangtang@163.com> - 2016-01-01 16:10 +0100
  [PATCH 3/7] input: touchscreen: use to_delayed_work Geliang Tang <geliangtang@163.com> - 2016-01-01 16:10 +0100
    Re: [PATCH 3/7] input: touchscreen: use to_delayed_work Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2016-01-03 06:10 +0100
  [PATCH 7/7] mvsas: use to_delayed_work Geliang Tang <geliangtang@163.com> - 2016-01-01 16:10 +0100
  [PATCH 2/7] edac: i5100_edac: use to_delayed_work Geliang Tang <geliangtang@163.com> - 2016-01-01 16:10 +0100
    Re: [PATCH 2/7] edac: i5100_edac: use to_delayed_work Borislav Petkov <bp@alien8.de> - 2016-01-01 18:40 +0100
  [PATCH 4/7] mmc: sh_mmcif: use to_delayed_work Geliang Tang <geliangtang@163.com> - 2016-01-01 16:10 +0100
  Re: [PATCH 1/7] char: xillybus: use to_delayed_work Eli Billauer <eli.billauer@gmail.com> - 2016-01-01 21:10 +0100

csiph-web