Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1282289 > unrolled thread

[PATCH] Input: psmouse - rename ps2pp_init() to ps2pp_detect()

Started byDmitry Torokhov <dmitry.torokhov@gmail.com>
First post2015-12-02 20:30 +0100
Last post2015-12-02 20:30 +0100
Articles 2 — 1 participant

Back to article view | Back to linux.kernel


Contents

  [PATCH] Input: psmouse - rename ps2pp_init() to ps2pp_detect() Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2015-12-02 20:30 +0100
    Re: [PATCH] Input: psmouse - rename ps2pp_init() to ps2pp_detect() Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2015-12-02 20:30 +0100

#1282289 — [PATCH] Input: psmouse - rename ps2pp_init() to ps2pp_detect()

FromDmitry Torokhov <dmitry.torokhov@gmail.com>
Date2015-12-02 20:30 +0100
Subject[PATCH] Input: psmouse - rename ps2pp_init() to ps2pp_detect()
Message-ID<qBlge-31N-11@gated-at.bofh.it>
This makes Logitech PS2++ protocol implementation consistent with
the naming in other protocols.

Signed-off-by: Dmitry Torokhov <dmitry.torokhov@gmail.com>
---
 drivers/input/mouse/logips2pp.h    | 4 ++--
 drivers/input/mouse/psmouse-base.c | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/input/mouse/logips2pp.h b/drivers/input/mouse/logips2pp.h
index 0c186f0..075fd32 100644
--- a/drivers/input/mouse/logips2pp.h
+++ b/drivers/input/mouse/logips2pp.h
@@ -12,9 +12,9 @@
 #define _LOGIPS2PP_H
 
 #ifdef CONFIG_MOUSE_PS2_LOGIPS2PP
-int ps2pp_init(struct psmouse *psmouse, bool set_properties);
+int ps2pp_detect(struct psmouse *psmouse, bool set_properties);
 #else
-inline int ps2pp_init(struct psmouse *psmouse, bool set_properties)
+static inline int ps2pp_detect(struct psmouse *psmouse, bool set_properties)
 {
 	return -ENOSYS;
 }
diff --git a/drivers/input/mouse/psmouse-base.c b/drivers/input/mouse/psmouse-base.c
index e909c6e..90d9218 100644
--- a/drivers/input/mouse/psmouse-base.c
+++ b/drivers/input/mouse/psmouse-base.c
@@ -699,7 +699,7 @@ static const struct psmouse_protocol psmouse_protocols[] = {
 		.type		= PSMOUSE_PS2PP,
 		.name		= "PS2++",
 		.alias		= "logitech",
-		.detect		= ps2pp_init,
+		.detect		= ps2pp_detect,
 	},
 #endif
 	{
-- 
2.6.0.rc2.230.g3dd15c0


-- 
Dmitry
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1282292

FromDmitry Torokhov <dmitry.torokhov@gmail.com>
Date2015-12-02 20:30 +0100
Message-ID<qBlge-31N-19@gated-at.bofh.it>
In reply to#1282289
On Wed, Dec 02, 2015 at 11:20:44AM -0800, Dmitry Torokhov wrote:
> This makes Logitech PS2++ protocol implementation consistent with
> the naming in other protocols.
> 
> Signed-off-by: Dmitry Torokhov <dmitry.torokhov@gmail.com>

Well, if I did not forget to add drivers/input/mouse/logips2pp.c that
woudl be better...

> ---
>  drivers/input/mouse/logips2pp.h    | 4 ++--
>  drivers/input/mouse/psmouse-base.c | 2 +-
>  2 files changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/input/mouse/logips2pp.h b/drivers/input/mouse/logips2pp.h
> index 0c186f0..075fd32 100644
> --- a/drivers/input/mouse/logips2pp.h
> +++ b/drivers/input/mouse/logips2pp.h
> @@ -12,9 +12,9 @@
>  #define _LOGIPS2PP_H
>  
>  #ifdef CONFIG_MOUSE_PS2_LOGIPS2PP
> -int ps2pp_init(struct psmouse *psmouse, bool set_properties);
> +int ps2pp_detect(struct psmouse *psmouse, bool set_properties);
>  #else
> -inline int ps2pp_init(struct psmouse *psmouse, bool set_properties)
> +static inline int ps2pp_detect(struct psmouse *psmouse, bool set_properties)
>  {
>  	return -ENOSYS;
>  }
> diff --git a/drivers/input/mouse/psmouse-base.c b/drivers/input/mouse/psmouse-base.c
> index e909c6e..90d9218 100644
> --- a/drivers/input/mouse/psmouse-base.c
> +++ b/drivers/input/mouse/psmouse-base.c
> @@ -699,7 +699,7 @@ static const struct psmouse_protocol psmouse_protocols[] = {
>  		.type		= PSMOUSE_PS2PP,
>  		.name		= "PS2++",
>  		.alias		= "logitech",
> -		.detect		= ps2pp_init,
> +		.detect		= ps2pp_detect,
>  	},
>  #endif
>  	{
> -- 
> 2.6.0.rc2.230.g3dd15c0
> 
> 
> -- 
> Dmitry

-- 
Dmitry
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web