Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1282292

Re: [PATCH] Input: psmouse - rename ps2pp_init() to ps2pp_detect()

From Dmitry Torokhov <dmitry.torokhov@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH] Input: psmouse - rename ps2pp_init() to ps2pp_detect()
Date 2015-12-02 20:30 +0100
Message-ID <qBlge-31N-19@gated-at.bofh.it> (permalink)
References <qBlge-31N-11@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Wed, Dec 02, 2015 at 11:20:44AM -0800, Dmitry Torokhov wrote:
> This makes Logitech PS2++ protocol implementation consistent with
> the naming in other protocols.
> 
> Signed-off-by: Dmitry Torokhov <dmitry.torokhov@gmail.com>

Well, if I did not forget to add drivers/input/mouse/logips2pp.c that
woudl be better...

> ---
>  drivers/input/mouse/logips2pp.h    | 4 ++--
>  drivers/input/mouse/psmouse-base.c | 2 +-
>  2 files changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/input/mouse/logips2pp.h b/drivers/input/mouse/logips2pp.h
> index 0c186f0..075fd32 100644
> --- a/drivers/input/mouse/logips2pp.h
> +++ b/drivers/input/mouse/logips2pp.h
> @@ -12,9 +12,9 @@
>  #define _LOGIPS2PP_H
>  
>  #ifdef CONFIG_MOUSE_PS2_LOGIPS2PP
> -int ps2pp_init(struct psmouse *psmouse, bool set_properties);
> +int ps2pp_detect(struct psmouse *psmouse, bool set_properties);
>  #else
> -inline int ps2pp_init(struct psmouse *psmouse, bool set_properties)
> +static inline int ps2pp_detect(struct psmouse *psmouse, bool set_properties)
>  {
>  	return -ENOSYS;
>  }
> diff --git a/drivers/input/mouse/psmouse-base.c b/drivers/input/mouse/psmouse-base.c
> index e909c6e..90d9218 100644
> --- a/drivers/input/mouse/psmouse-base.c
> +++ b/drivers/input/mouse/psmouse-base.c
> @@ -699,7 +699,7 @@ static const struct psmouse_protocol psmouse_protocols[] = {
>  		.type		= PSMOUSE_PS2PP,
>  		.name		= "PS2++",
>  		.alias		= "logitech",
> -		.detect		= ps2pp_init,
> +		.detect		= ps2pp_detect,
>  	},
>  #endif
>  	{
> -- 
> 2.6.0.rc2.230.g3dd15c0
> 
> 
> -- 
> Dmitry

-- 
Dmitry
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH] Input: psmouse - rename ps2pp_init() to ps2pp_detect() Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2015-12-02 20:30 +0100
  Re: [PATCH] Input: psmouse - rename ps2pp_init() to ps2pp_detect() Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2015-12-02 20:30 +0100

csiph-web