Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1222489 > unrolled thread

[PATCH] kasan: use IS_ALIGNED in memory_is_poisoned_8()

Started byXishi Qiu <qiuxishi@huawei.com>
First post2015-09-11 04:10 +0200
Last post2015-09-14 15:20 +0200
Articles 4 — 3 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH] kasan: use IS_ALIGNED in memory_is_poisoned_8() Xishi Qiu <qiuxishi@huawei.com> - 2015-09-11 04:10 +0200
    Re: [PATCH] kasan: use IS_ALIGNED in memory_is_poisoned_8() Andrew Morton <akpm@linux-foundation.org> - 2015-09-12 00:50 +0200
      Re: [PATCH] kasan: use IS_ALIGNED in memory_is_poisoned_8() Xishi Qiu <qiuxishi@huawei.com> - 2015-09-14 03:20 +0200
      Re: [PATCH] kasan: use IS_ALIGNED in memory_is_poisoned_8() Andrey Ryabinin <ryabinin.a.a@gmail.com> - 2015-09-14 15:20 +0200

#1222489 — [PATCH] kasan: use IS_ALIGNED in memory_is_poisoned_8()

FromXishi Qiu <qiuxishi@huawei.com>
Date2015-09-11 04:10 +0200
Subject[PATCH] kasan: use IS_ALIGNED in memory_is_poisoned_8()
Message-ID<q7lWO-441-31@gated-at.bofh.it>
Use IS_ALIGNED() to determine whether the shadow span two bytes.
It generates less code and more readable.

Signed-off-by: Xishi Qiu <qiuxishi@huawei.com>
---
 mm/kasan/kasan.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/mm/kasan/kasan.c b/mm/kasan/kasan.c
index 7b28e9c..c6ddff1 100644
--- a/mm/kasan/kasan.c
+++ b/mm/kasan/kasan.c
@@ -120,7 +120,7 @@ static __always_inline bool memory_is_poisoned_8(unsigned long addr)
 		if (memory_is_poisoned_1(addr + 7))
 			return true;
 
-		if (likely(((addr + 7) & KASAN_SHADOW_MASK) >= 7))
+		if (likely(IS_ALIGNED(addr, 8)))
 			return false;
 
 		return unlikely(*(u8 *)shadow_addr);
-- 
2.0.0


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1223144

FromAndrew Morton <akpm@linux-foundation.org>
Date2015-09-12 00:50 +0200
Message-ID<q7FiN-75P-11@gated-at.bofh.it>
In reply to#1222489
On Fri, 11 Sep 2015 10:02:29 +0800 Xishi Qiu <qiuxishi@huawei.com> wrote:

> Use IS_ALIGNED() to determine whether the shadow span two bytes.
> It generates less code and more readable.
> 

Please cc Andrey Ryabinin on kasan patches.

> --- a/mm/kasan/kasan.c
> +++ b/mm/kasan/kasan.c
> @@ -120,7 +120,7 @@ static __always_inline bool memory_is_poisoned_8(unsigned long addr)
>  		if (memory_is_poisoned_1(addr + 7))
>  			return true;
>  
> -		if (likely(((addr + 7) & KASAN_SHADOW_MASK) >= 7))
> +		if (likely(IS_ALIGNED(addr, 8)))
>  			return false;

Wouldn't IS_ALIGNED(addr, KASAN_SHADOW_SCALE_SIZE) be more appropriate?

But I'm not really sure what the original code is trying to do.

	if ((addr + 7) & 7) >= 7)

can only evaluate true if ((addr + 7) & 7) equals 7, so the ">=" could
be "==".

I think.  The code looks a bit weird.  A code comment would help.

And how come memory_is_poisoned_16() does IS_ALIGNED(addr, 8)?  Should
it be 16?

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1223785

FromXishi Qiu <qiuxishi@huawei.com>
Date2015-09-14 03:20 +0200
Message-ID<q8qB3-7VT-1@gated-at.bofh.it>
In reply to#1223144
On 2015/9/12 6:47, Andrew Morton wrote:

> On Fri, 11 Sep 2015 10:02:29 +0800 Xishi Qiu <qiuxishi@huawei.com> wrote:
> 
>> Use IS_ALIGNED() to determine whether the shadow span two bytes.
>> It generates less code and more readable.
>>
> 
> Please cc Andrey Ryabinin on kasan patches.

Sorry, my mistake.

> 
>> --- a/mm/kasan/kasan.c
>> +++ b/mm/kasan/kasan.c
>> @@ -120,7 +120,7 @@ static __always_inline bool memory_is_poisoned_8(unsigned long addr)
>>  		if (memory_is_poisoned_1(addr + 7))
>>  			return true;
>>  
>> -		if (likely(((addr + 7) & KASAN_SHADOW_MASK) >= 7))
>> +		if (likely(IS_ALIGNED(addr, 8)))
>>  			return false;
> 
> Wouldn't IS_ALIGNED(addr, KASAN_SHADOW_SCALE_SIZE) be more appropriate?
> 

OK, I'll send V2.

> But I'm not really sure what the original code is trying to do.
> 
> 	if ((addr + 7) & 7) >= 7)
> 
> can only evaluate true if ((addr + 7) & 7) equals 7, so the ">=" could
> be "==".
> 

I think it should be "==", the value will not "> 7"

> I think.  The code looks a bit weird.  A code comment would help.
> 
> And how come memory_is_poisoned_16() does IS_ALIGNED(addr, 8)?  Should
> it be 16?

No, it is to determine whether the shadow span two bytes(8 bytes, not 16).

Thanks,
Xishi Qiu

> 
> 
> .
> 



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1224126

FromAndrey Ryabinin <ryabinin.a.a@gmail.com>
Date2015-09-14 15:20 +0200
Message-ID<q8BPP-7hh-9@gated-at.bofh.it>
In reply to#1223144
2015-09-12 1:47 GMT+03:00 Andrew Morton <akpm@linux-foundation.org>:
> On Fri, 11 Sep 2015 10:02:29 +0800 Xishi Qiu <qiuxishi@huawei.com> wrote:
>> -             if (likely(((addr + 7) & KASAN_SHADOW_MASK) >= 7))
>> +             if (likely(IS_ALIGNED(addr, 8)))
>>                       return false;
>
> Wouldn't IS_ALIGNED(addr, KASAN_SHADOW_SCALE_SIZE) be more appropriate?
>
> But I'm not really sure what the original code is trying to do.
>

Original code is trying to estimate whether we should check 2 shadow
bytes or just 1 should be enough.

>         if ((addr + 7) & 7) >= 7)
>
> can only evaluate true if ((addr + 7) & 7) equals 7, so the ">=" could
> be "==".
>

Yes, it could be "==".
">=" is just for consistency with similar code in memory_is_poisoned_2/4.

If I'm not mistaken generic formula for such check looks like this:
        ((addr + size - 1) & KASAN_SHADOW_MASK) >= ((size - 1) &
KASAN_SHADOW_MASK)

But when size >= KASAN_SHADOW_SCALE_SIZE we could just check for alignment.

> I think.  The code looks a bit weird.  A code comment would help.
>
> And how come memory_is_poisoned_16() does IS_ALIGNED(addr, 8)?  Should
> it be 16?
>

No, If 16 bytes are 8-byte aligned, then shadow is 2-bytes.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web