Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1223144
| From | Andrew Morton <akpm@linux-foundation.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] kasan: use IS_ALIGNED in memory_is_poisoned_8() |
| Date | 2015-09-12 00:50 +0200 |
| Message-ID | <q7FiN-75P-11@gated-at.bofh.it> (permalink) |
| References | <q7lWO-441-31@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Fri, 11 Sep 2015 10:02:29 +0800 Xishi Qiu <qiuxishi@huawei.com> wrote: > Use IS_ALIGNED() to determine whether the shadow span two bytes. > It generates less code and more readable. > Please cc Andrey Ryabinin on kasan patches. > --- a/mm/kasan/kasan.c > +++ b/mm/kasan/kasan.c > @@ -120,7 +120,7 @@ static __always_inline bool memory_is_poisoned_8(unsigned long addr) > if (memory_is_poisoned_1(addr + 7)) > return true; > > - if (likely(((addr + 7) & KASAN_SHADOW_MASK) >= 7)) > + if (likely(IS_ALIGNED(addr, 8))) > return false; Wouldn't IS_ALIGNED(addr, KASAN_SHADOW_SCALE_SIZE) be more appropriate? But I'm not really sure what the original code is trying to do. if ((addr + 7) & 7) >= 7) can only evaluate true if ((addr + 7) & 7) equals 7, so the ">=" could be "==". I think. The code looks a bit weird. A code comment would help. And how come memory_is_poisoned_16() does IS_ALIGNED(addr, 8)? Should it be 16? -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] kasan: use IS_ALIGNED in memory_is_poisoned_8() Xishi Qiu <qiuxishi@huawei.com> - 2015-09-11 04:10 +0200
Re: [PATCH] kasan: use IS_ALIGNED in memory_is_poisoned_8() Andrew Morton <akpm@linux-foundation.org> - 2015-09-12 00:50 +0200
Re: [PATCH] kasan: use IS_ALIGNED in memory_is_poisoned_8() Xishi Qiu <qiuxishi@huawei.com> - 2015-09-14 03:20 +0200
Re: [PATCH] kasan: use IS_ALIGNED in memory_is_poisoned_8() Andrey Ryabinin <ryabinin.a.a@gmail.com> - 2015-09-14 15:20 +0200
csiph-web