Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1221669 > unrolled thread

Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to sm750_sw_i2c_init

Started byGreg Kroah-Hartman <greg@kroah.com>
First post2015-09-09 22:00 +0200
Last post2015-09-09 22:10 +0200
Articles 7 — 3 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to  sm750_sw_i2c_init Greg Kroah-Hartman <greg@kroah.com> - 2015-09-09 22:00 +0200
    Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to  sm750_sw_i2c_init Greg Kroah-Hartman <greg@kroah.com> - 2015-09-09 22:10 +0200
      Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to  sm750_sw_i2c_init Sudip Mukherjee <sudipm.mukherjee@gmail.com> - 2015-09-10 06:50 +0200
        Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to  sm750_sw_i2c_init Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-10 14:50 +0200
          Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to  sm750_sw_i2c_init Sudip Mukherjee <sudipm.mukherjee@gmail.com> - 2015-09-10 15:10 +0200
            Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to  sm750_sw_i2c_init Greg Kroah-Hartman <greg@kroah.com> - 2015-09-12 06:40 +0200
    Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to  sm750_sw_i2c_init Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-09 22:10 +0200

#1221669 — Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to sm750_sw_i2c_init

FromGreg Kroah-Hartman <greg@kroah.com>
Date2015-09-09 22:00 +0200
SubjectRe: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to sm750_sw_i2c_init
Message-ID<q6THc-4vo-15@gated-at.bofh.it>
On Sun, Sep 06, 2015 at 09:17:56AM +0300, Mike Rapoport wrote:
> Fix the checkpatch warning about CamelCase.
> 
> Signed-off-by: Mike Rapoport <mike.rapoport@gmail.com>
> ---
>  drivers/staging/sm750fb/ddk750_sii164.c | 2 +-
>  drivers/staging/sm750fb/ddk750_swi2c.c  | 2 +-
>  drivers/staging/sm750fb/ddk750_swi2c.h  | 2 +-
>  drivers/staging/sm750fb/sm750_hw.c      | 2 +-
>  4 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/staging/sm750fb/ddk750_sii164.c b/drivers/staging/sm750fb/ddk750_sii164.c
> index 3d129aa..241b77b 100644
> --- a/drivers/staging/sm750fb/ddk750_sii164.c
> +++ b/drivers/staging/sm750fb/ddk750_sii164.c
> @@ -132,7 +132,7 @@ long sii164InitChip(
>  	/* Use fast mode. */
>  	sm750_hw_i2c_init(1);
>  #else
> -	swI2CInit(DEFAULT_I2C_SCL, DEFAULT_I2C_SDA);
> +	sm750_sw_i2c_init(DEFAULT_I2C_SCL, DEFAULT_I2C_SDA);

Hm, wait, "sw_"?  what is the difference between the hw and sw versions?

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [next] | [standalone]


#1221686

FromGreg Kroah-Hartman <greg@kroah.com>
Date2015-09-09 22:10 +0200
Message-ID<q6TQS-4VR-9@gated-at.bofh.it>
In reply to#1221669
On Wed, Sep 09, 2015 at 11:03:20PM +0300, Mike Rapoport wrote:
> On Wed, Sep 09, 2015 at 11:41:20AM -0700, Greg Kroah-Hartman wrote:
> > On Sun, Sep 06, 2015 at 09:17:56AM +0300, Mike Rapoport wrote:
> > > Fix the checkpatch warning about CamelCase.
> > > 
> > > Signed-off-by: Mike Rapoport <mike.rapoport@gmail.com>
> > > ---
> > >  drivers/staging/sm750fb/ddk750_sii164.c | 2 +-
> > >  drivers/staging/sm750fb/ddk750_swi2c.c  | 2 +-
> > >  drivers/staging/sm750fb/ddk750_swi2c.h  | 2 +-
> > >  drivers/staging/sm750fb/sm750_hw.c      | 2 +-
> > >  4 files changed, 4 insertions(+), 4 deletions(-)
> > > 
> > > diff --git a/drivers/staging/sm750fb/ddk750_sii164.c b/drivers/staging/sm750fb/ddk750_sii164.c
> > > index 3d129aa..241b77b 100644
> > > --- a/drivers/staging/sm750fb/ddk750_sii164.c
> > > +++ b/drivers/staging/sm750fb/ddk750_sii164.c
> > > @@ -132,7 +132,7 @@ long sii164InitChip(
> > >  	/* Use fast mode. */
> > >  	sm750_hw_i2c_init(1);
> > >  #else
> > > -	swI2CInit(DEFAULT_I2C_SCL, DEFAULT_I2C_SDA);
> > > +	sm750_sw_i2c_init(DEFAULT_I2C_SCL, DEFAULT_I2C_SDA);
> > 
> > Hm, wait, "sw_"?  what is the difference between the hw and sw versions?
> 
> As far as I understood, the intention for HW is for using i2c
> controller, and SW is for using gpio bit-bang

big-bang i2c?  ick.

Ok, maybe your original choices made more sense.  Can you review them
again and resend if you feel they are ok?  They are now gone from my
queue, sorry.

thanks,

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1221913

FromSudip Mukherjee <sudipm.mukherjee@gmail.com>
Date2015-09-10 06:50 +0200
Message-ID<q71Y5-81v-1@gated-at.bofh.it>
In reply to#1221686
On Wed, Sep 09, 2015 at 01:07:04PM -0700, Greg Kroah-Hartman wrote:
> On Wed, Sep 09, 2015 at 11:03:20PM +0300, Mike Rapoport wrote:
> > On Wed, Sep 09, 2015 at 11:41:20AM -0700, Greg Kroah-Hartman wrote:
> > > On Sun, Sep 06, 2015 at 09:17:56AM +0300, Mike Rapoport wrote:
> > > > Fix the checkpatch warning about CamelCase.
> > > > 
> > > > Signed-off-by: Mike Rapoport <mike.rapoport@gmail.com>
> > > > ---
> > > >  drivers/staging/sm750fb/ddk750_sii164.c | 2 +-
> > > >  drivers/staging/sm750fb/ddk750_swi2c.c  | 2 +-
> > > >  drivers/staging/sm750fb/ddk750_swi2c.h  | 2 +-
> > > >  drivers/staging/sm750fb/sm750_hw.c      | 2 +-
> > > >  4 files changed, 4 insertions(+), 4 deletions(-)
> > > > 
> > > > diff --git a/drivers/staging/sm750fb/ddk750_sii164.c b/drivers/staging/sm750fb/ddk750_sii164.c
> > > > index 3d129aa..241b77b 100644
> > > > --- a/drivers/staging/sm750fb/ddk750_sii164.c
> > > > +++ b/drivers/staging/sm750fb/ddk750_sii164.c
> > > > @@ -132,7 +132,7 @@ long sii164InitChip(
> > > >  	/* Use fast mode. */
> > > >  	sm750_hw_i2c_init(1);
> > > >  #else
> > > > -	swI2CInit(DEFAULT_I2C_SCL, DEFAULT_I2C_SDA);
> > > > +	sm750_sw_i2c_init(DEFAULT_I2C_SCL, DEFAULT_I2C_SDA);
> > > 
> > > Hm, wait, "sw_"?  what is the difference between the hw and sw versions?
> > 
> > As far as I understood, the intention for HW is for using i2c
> > controller, and SW is for using gpio bit-bang
> 
> big-bang i2c?  ick.
:(
Yes, there is a special version of SM750 which uses sw i2c.
SM750LE is a special version which only Huawei uses.

regards
sudip
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1222170

FromMike Rapoport <mike.rapoport@gmail.com>
Date2015-09-10 14:50 +0200
Message-ID<q79sC-1Gc-15@gated-at.bofh.it>
In reply to#1221913
Hi Sudip,

On Thu, Sep 10, 2015 at 10:10:19AM +0530, Sudip Mukherjee wrote:
> On Wed, Sep 09, 2015 at 01:07:04PM -0700, Greg Kroah-Hartman wrote:
> > > 
> > > As far as I understood, the intention for HW is for using i2c
> > > controller, and SW is for using gpio bit-bang
> > 
> > big-bang i2c?  ick.
> :(
> Yes, there is a special version of SM750 which uses sw i2c.
> SM750LE is a special version which only Huawei uses.

If I'm not mistaken, device variant can be identified in run-time and
i2c implementation may be selected accordingly. Am I right?
 
> regards
> sudip

--
Sincerely yours,
Mike.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1222178

FromSudip Mukherjee <sudipm.mukherjee@gmail.com>
Date2015-09-10 15:10 +0200
Message-ID<q79LY-2hY-17@gated-at.bofh.it>
In reply to#1222170
On Thu, Sep 10, 2015 at 03:39:58PM +0300, Mike Rapoport wrote:
> Hi Sudip,
> 
> On Thu, Sep 10, 2015 at 10:10:19AM +0530, Sudip Mukherjee wrote:
> > On Wed, Sep 09, 2015 at 01:07:04PM -0700, Greg Kroah-Hartman wrote:
> > > > 
> > > > As far as I understood, the intention for HW is for using i2c
> > > > controller, and SW is for using gpio bit-bang
> > > 
> > > big-bang i2c?  ick.
> > :(
> > Yes, there is a special version of SM750 which uses sw i2c.
> > SM750LE is a special version which only Huawei uses.
> 
> If I'm not mistaken, device variant can be identified in run-time and
> i2c implementation may be selected accordingly. Am I right?
Yes, that is a possibility but I do not have this SM750LE hardware, so
if anything breaks in the sw i2c while trying to unify these two i2c
codes, I will not be able to test.
Maybe Greg can give some idea here about how to proceed.

regards
sudip
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1223307

FromGreg Kroah-Hartman <greg@kroah.com>
Date2015-09-12 06:40 +0200
Message-ID<q7KLw-6L3-23@gated-at.bofh.it>
In reply to#1222178
On Thu, Sep 10, 2015 at 06:31:08PM +0530, Sudip Mukherjee wrote:
> On Thu, Sep 10, 2015 at 03:39:58PM +0300, Mike Rapoport wrote:
> > Hi Sudip,
> > 
> > On Thu, Sep 10, 2015 at 10:10:19AM +0530, Sudip Mukherjee wrote:
> > > On Wed, Sep 09, 2015 at 01:07:04PM -0700, Greg Kroah-Hartman wrote:
> > > > > 
> > > > > As far as I understood, the intention for HW is for using i2c
> > > > > controller, and SW is for using gpio bit-bang
> > > > 
> > > > big-bang i2c?  ick.
> > > :(
> > > Yes, there is a special version of SM750 which uses sw i2c.
> > > SM750LE is a special version which only Huawei uses.
> > 
> > If I'm not mistaken, device variant can be identified in run-time and
> > i2c implementation may be selected accordingly. Am I right?
> Yes, that is a possibility but I do not have this SM750LE hardware, so
> if anything breaks in the sw i2c while trying to unify these two i2c
> codes, I will not be able to test.
> Maybe Greg can give some idea here about how to proceed.

No idea, sorry.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [next] | [standalone]


#1221687

FromMike Rapoport <mike.rapoport@gmail.com>
Date2015-09-09 22:10 +0200
Message-ID<q6TQS-4VR-7@gated-at.bofh.it>
In reply to#1221669
On Wed, Sep 09, 2015 at 11:41:20AM -0700, Greg Kroah-Hartman wrote:
> On Sun, Sep 06, 2015 at 09:17:56AM +0300, Mike Rapoport wrote:
> > Fix the checkpatch warning about CamelCase.
> > 
> > Signed-off-by: Mike Rapoport <mike.rapoport@gmail.com>
> > ---
> >  drivers/staging/sm750fb/ddk750_sii164.c | 2 +-
> >  drivers/staging/sm750fb/ddk750_swi2c.c  | 2 +-
> >  drivers/staging/sm750fb/ddk750_swi2c.h  | 2 +-
> >  drivers/staging/sm750fb/sm750_hw.c      | 2 +-
> >  4 files changed, 4 insertions(+), 4 deletions(-)
> > 
> > diff --git a/drivers/staging/sm750fb/ddk750_sii164.c b/drivers/staging/sm750fb/ddk750_sii164.c
> > index 3d129aa..241b77b 100644
> > --- a/drivers/staging/sm750fb/ddk750_sii164.c
> > +++ b/drivers/staging/sm750fb/ddk750_sii164.c
> > @@ -132,7 +132,7 @@ long sii164InitChip(
> >  	/* Use fast mode. */
> >  	sm750_hw_i2c_init(1);
> >  #else
> > -	swI2CInit(DEFAULT_I2C_SCL, DEFAULT_I2C_SDA);
> > +	sm750_sw_i2c_init(DEFAULT_I2C_SCL, DEFAULT_I2C_SDA);
> 
> Hm, wait, "sw_"?  what is the difference between the hw and sw versions?

As far as I understood, the intention for HW is for using i2c
controller, and SW is for using gpio bit-bang

--
Sincerely yours,
Mike. 
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web