Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1221686

Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to sm750_sw_i2c_init

From Greg Kroah-Hartman <greg@kroah.com>
Newsgroups linux.kernel
Subject Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to sm750_sw_i2c_init
Date 2015-09-09 22:10 +0200
Message-ID <q6TQS-4VR-9@gated-at.bofh.it> (permalink)
References <q5BsZ-7lc-3@gated-at.bofh.it> <q5BsZ-7lc-5@gated-at.bofh.it> <q6THc-4vo-15@gated-at.bofh.it> <q6TQS-4VR-7@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Wed, Sep 09, 2015 at 11:03:20PM +0300, Mike Rapoport wrote:
> On Wed, Sep 09, 2015 at 11:41:20AM -0700, Greg Kroah-Hartman wrote:
> > On Sun, Sep 06, 2015 at 09:17:56AM +0300, Mike Rapoport wrote:
> > > Fix the checkpatch warning about CamelCase.
> > > 
> > > Signed-off-by: Mike Rapoport <mike.rapoport@gmail.com>
> > > ---
> > >  drivers/staging/sm750fb/ddk750_sii164.c | 2 +-
> > >  drivers/staging/sm750fb/ddk750_swi2c.c  | 2 +-
> > >  drivers/staging/sm750fb/ddk750_swi2c.h  | 2 +-
> > >  drivers/staging/sm750fb/sm750_hw.c      | 2 +-
> > >  4 files changed, 4 insertions(+), 4 deletions(-)
> > > 
> > > diff --git a/drivers/staging/sm750fb/ddk750_sii164.c b/drivers/staging/sm750fb/ddk750_sii164.c
> > > index 3d129aa..241b77b 100644
> > > --- a/drivers/staging/sm750fb/ddk750_sii164.c
> > > +++ b/drivers/staging/sm750fb/ddk750_sii164.c
> > > @@ -132,7 +132,7 @@ long sii164InitChip(
> > >  	/* Use fast mode. */
> > >  	sm750_hw_i2c_init(1);
> > >  #else
> > > -	swI2CInit(DEFAULT_I2C_SCL, DEFAULT_I2C_SDA);
> > > +	sm750_sw_i2c_init(DEFAULT_I2C_SCL, DEFAULT_I2C_SDA);
> > 
> > Hm, wait, "sw_"?  what is the difference between the hw and sw versions?
> 
> As far as I understood, the intention for HW is for using i2c
> controller, and SW is for using gpio bit-bang

big-bang i2c?  ick.

Ok, maybe your original choices made more sense.  Can you review them
again and resend if you feel they are ok?  They are now gone from my
queue, sorry.

thanks,

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to  sm750_sw_i2c_init Greg Kroah-Hartman <greg@kroah.com> - 2015-09-09 22:00 +0200
  Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to  sm750_sw_i2c_init Greg Kroah-Hartman <greg@kroah.com> - 2015-09-09 22:10 +0200
    Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to  sm750_sw_i2c_init Sudip Mukherjee <sudipm.mukherjee@gmail.com> - 2015-09-10 06:50 +0200
      Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to  sm750_sw_i2c_init Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-10 14:50 +0200
        Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to  sm750_sw_i2c_init Sudip Mukherjee <sudipm.mukherjee@gmail.com> - 2015-09-10 15:10 +0200
          Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to  sm750_sw_i2c_init Greg Kroah-Hartman <greg@kroah.com> - 2015-09-12 06:40 +0200
  Re: [PATCH v3 06/17] staging: sm750fb: rename swI2CInit to  sm750_sw_i2c_init Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-09 22:10 +0200

csiph-web