Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1218726 > unrolled thread
| Started by | Mike Rapoport <mike.rapoport@gmail.com> |
|---|---|
| First post | 2015-09-04 10:20 +0200 |
| Last post | 2015-09-04 10:30 +0200 |
| Articles | 4 on this page of 24 — 2 participants |
Back to article view | Back to linux.kernel
[PATCH v2 00/17] staging: sm750fb: coding style fixes Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:20 +0200
[PATCH v2 04/17] staging: sm750fb: rename hwI2CWriteReg to sm750_hw_i2c_write_reg Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:20 +0200
[PATCH v2 05/17] staging: sm750fb: ddk750_hwi2c: rename CamelCase static functions Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:20 +0200
[PATCH v2 03/17] staging: sm750fb: rename hwI2CReadReg to sm750_hw_i2c_read_reg Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:20 +0200
[PATCH v2 11/17] staging: sm750fb: ddk750_hw_i2c: rename busSpeedMode Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:30 +0200
[PATCH v2 13/17] staging: sm750fb: ddk750_hwi2c: reduce amount of CamelCase Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:30 +0200
[PATCH v2 10/17] staging: sm750fb: ddk750_swi2c: rename CamelCase static functions Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:30 +0200
Re: [PATCH v2 10/17] staging: sm750fb: ddk750_swi2c: rename CamelCase static functions Sudip Mukherjee <sudipm.mukherjee@gmail.com> - 2015-09-04 14:30 +0200
Re: [PATCH v2 10/17] staging: sm750fb: ddk750_swi2c: rename CamelCase static functions Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-05 21:10 +0200
[PATCH v2 01/17] staging: sm750fb: rename hwI2CInit to sm750_hw_i2c_init Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:30 +0200
[PATCH v2 14/17] staging: sm750fb: ddk750_swi2c: rename CamelCase static variables Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:30 +0200
[PATCH v2 15/17] staging: sm750fb: ddk750_swi2c: further reduce CamelCase Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:30 +0200
[PATCH v2 02/17] staging: sm750fb: rename hwI2CClose to sm750_hw_i2c_close Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:30 +0200
[PATCH v2 08/17] staging: sm750fb: rename swI2CWriteReg to sm750_sw_i2c_write_reg Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:30 +0200
[PATCH v2 16/17] staging: sm750fb: ddk750_*i2c: remove multiple blank lines Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:30 +0200
[PATCH v2 17/17] staging: sm750fb: ddk750_*i2c: shorten lines to under 80 characters Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:30 +0200
[PATCH v2 09/17] staging: sm750fb: ddk750_swi2c: staticize swI2C{SCL,SDA} Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:30 +0200
Re: [PATCH v2 09/17] staging: sm750fb: ddk750_swi2c: staticize swI2C{SCL,SDA} Sudip Mukherjee <sudipm.mukherjee@gmail.com> - 2015-09-04 14:20 +0200
Re: [PATCH v2 09/17] staging: sm750fb: ddk750_swi2c: staticize swI2C{SCL,SDA} Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-05 21:00 +0200
[PATCH v2 06/17] staging: sm750fb: rename swI2CInit to sm750_sw_i2c_init Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:30 +0200
[PATCH v2 12/17] staging: sm750fb: hw_i2c_{read,write}: rename CamelCase variables Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:30 +0200
Re: [PATCH v2 12/17] staging: sm750fb: hw_i2c_{read,write}: rename CamelCase variables Sudip Mukherjee <sudipm.mukherjee@gmail.com> - 2015-09-04 14:30 +0200
Re: [PATCH v2 12/17] staging: sm750fb: hw_i2c_{read,write}: rename CamelCase variables Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-05 21:00 +0200
[PATCH v2 07/17] staging: sm750fb: rename swI2CReadReg to sm750_sw_i2c_read_reg Mike Rapoport <mike.rapoport@gmail.com> - 2015-09-04 10:30 +0200
Page 2 of 2 — ← Prev page 1 [2]
| From | Mike Rapoport <mike.rapoport@gmail.com> |
|---|---|
| Date | 2015-09-04 10:30 +0200 |
| Subject | [PATCH v2 12/17] staging: sm750fb: hw_i2c_{read,write}: rename CamelCase variables |
| Message-ID | <q4UxJ-51q-39@gated-at.bofh.it> |
| In reply to | #1218726 |
Rename longCamelCase variables deviceAddress and registerIndex to
shorter addr and reg
Signed-off-by: Mike Rapoport <mike.rapoport@gmail.com>
---
drivers/staging/sm750fb/ddk750_hwi2c.c | 16 ++++++++--------
drivers/staging/sm750fb/ddk750_hwi2c.h | 4 ++--
2 files changed, 10 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/sm750fb/ddk750_hwi2c.c b/drivers/staging/sm750fb/ddk750_hwi2c.c
index a35505d..e44b2f5 100644
--- a/drivers/staging/sm750fb/ddk750_hwi2c.c
+++ b/drivers/staging/sm750fb/ddk750_hwi2c.c
@@ -220,14 +220,14 @@ static unsigned int hw_i2c_read_data(
* Register value
*/
unsigned char sm750_hw_i2c_read_reg(
- unsigned char deviceAddress,
- unsigned char registerIndex
+ unsigned char addr,
+ unsigned char reg
)
{
unsigned char value = (0xFF);
- if (hw_i2c_write_data(deviceAddress, 1, ®isterIndex) == 1)
- hw_i2c_read_data(deviceAddress, 1, &value);
+ if (hw_i2c_write_data(addr, 1, ®) == 1)
+ hw_i2c_read_data(addr, 1, &value);
return value;
}
@@ -250,16 +250,16 @@ unsigned char sm750_hw_i2c_read_reg(
* -1 - Fail
*/
int sm750_hw_i2c_write_reg(
- unsigned char deviceAddress,
- unsigned char registerIndex,
+ unsigned char addr,
+ unsigned char reg,
unsigned char data
)
{
unsigned char value[2];
- value[0] = registerIndex;
+ value[0] = reg;
value[1] = data;
- if (hw_i2c_write_data(deviceAddress, 2, value) == 2)
+ if (hw_i2c_write_data(dev, 2, value) == 2)
return 0;
return (-1);
diff --git a/drivers/staging/sm750fb/ddk750_hwi2c.h b/drivers/staging/sm750fb/ddk750_hwi2c.h
index 5872f9c..2827865 100644
--- a/drivers/staging/sm750fb/ddk750_hwi2c.h
+++ b/drivers/staging/sm750fb/ddk750_hwi2c.h
@@ -5,6 +5,6 @@
int sm750_hw_i2c_init(unsigned char bus_speed_mode);
void sm750_hw_i2c_close(void);
-unsigned char sm750_hw_i2c_read_reg(unsigned char deviceAddress, unsigned char registerIndex);
-int sm750_hw_i2c_write_reg(unsigned char deviceAddress, unsigned char registerIndex, unsigned char data);
+unsigned char sm750_hw_i2c_read_reg(unsigned char addr, unsigned char reg);
+int sm750_hw_i2c_write_reg(unsigned char addr, unsigned char reg, unsigned char data);
#endif
--
2.1.0
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Sudip Mukherjee <sudipm.mukherjee@gmail.com> |
|---|---|
| Date | 2015-09-04 14:30 +0200 |
| Subject | Re: [PATCH v2 12/17] staging: sm750fb: hw_i2c_{read,write}: rename CamelCase variables |
| Message-ID | <q4YhY-1XT-29@gated-at.bofh.it> |
| In reply to | #1218756 |
On Fri, Sep 04, 2015 at 11:18:57AM +0300, Mike Rapoport wrote: > Rename longCamelCase variables deviceAddress and registerIndex to > shorter addr and reg > > Signed-off-by: Mike Rapoport <mike.rapoport@gmail.com> > --- Please build test before sending. This patch breaks the build. regards sudip -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Mike Rapoport <mike.rapoport@gmail.com> |
|---|---|
| Date | 2015-09-05 21:00 +0200 |
| Subject | Re: [PATCH v2 12/17] staging: sm750fb: hw_i2c_{read,write}: rename CamelCase variables |
| Message-ID | <q5qQW-tO-11@gated-at.bofh.it> |
| In reply to | #1218890 |
On Fri, Sep 04, 2015 at 05:53:44PM +0530, Sudip Mukherjee wrote: > On Fri, Sep 04, 2015 at 11:18:57AM +0300, Mike Rapoport wrote: > > Rename longCamelCase variables deviceAddress and registerIndex to > > shorter addr and reg > > > > Signed-off-by: Mike Rapoport <mike.rapoport@gmail.com> > > --- > Please build test before sending. This patch breaks the build. will fix > regards > sudip -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Mike Rapoport <mike.rapoport@gmail.com> |
|---|---|
| Date | 2015-09-04 10:30 +0200 |
| Subject | [PATCH v2 07/17] staging: sm750fb: rename swI2CReadReg to sm750_sw_i2c_read_reg |
| Message-ID | <q4UxJ-51q-45@gated-at.bofh.it> |
| In reply to | #1218726 |
Fix the checkpatch warning about CamelCase.
Signed-off-by: Mike Rapoport <mike.rapoport@gmail.com>
---
drivers/staging/sm750fb/ddk750_swi2c.c | 2 +-
drivers/staging/sm750fb/ddk750_swi2c.h | 2 +-
drivers/staging/sm750fb/sm750_hw.c | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/sm750fb/ddk750_swi2c.c b/drivers/staging/sm750fb/ddk750_swi2c.c
index ecfd300..765edd6 100644
--- a/drivers/staging/sm750fb/ddk750_swi2c.c
+++ b/drivers/staging/sm750fb/ddk750_swi2c.c
@@ -443,7 +443,7 @@ long sm750_sw_i2c_init(
* Return Value:
* Register value
*/
-unsigned char swI2CReadReg(
+unsigned char sm750_sw_i2c_read_reg(
unsigned char deviceAddress,
unsigned char registerIndex
)
diff --git a/drivers/staging/sm750fb/ddk750_swi2c.h b/drivers/staging/sm750fb/ddk750_swi2c.h
index 1e18b80..2e87a63 100644
--- a/drivers/staging/sm750fb/ddk750_swi2c.h
+++ b/drivers/staging/sm750fb/ddk750_swi2c.h
@@ -44,7 +44,7 @@ long sm750_sw_i2c_init(
* Return Value:
* Register value
*/
-unsigned char swI2CReadReg(
+unsigned char sm750_sw_i2c_read_reg(
unsigned char deviceAddress,
unsigned char registerIndex
);
diff --git a/drivers/staging/sm750fb/sm750_hw.c b/drivers/staging/sm750fb/sm750_hw.c
index 522736e..b8b5e00 100644
--- a/drivers/staging/sm750fb/sm750_hw.c
+++ b/drivers/staging/sm750fb/sm750_hw.c
@@ -175,7 +175,7 @@ int hw_sm750_inithw(struct lynx_share *share, struct pci_dev *pdev)
/* Customer may NOT use CH7301 DVI chip, which has to be
initialized differently.
*/
- if (swI2CReadReg(0xec, 0x4a) == 0x95) {
+ if (sm750_sw_i2c_read_reg(0xec, 0x4a) == 0x95) {
/* The following register values for CH7301 are from
Chrontel app note and our experiment.
*/
--
2.1.0
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [standalone]
Page 2 of 2 — ← Prev page 1 [2]
Back to top | Article view | linux.kernel
csiph-web