Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1175567 > unrolled thread
| Started by | David Rientjes <rientjes@google.com> |
|---|---|
| First post | 2015-07-01 23:50 +0200 |
| Last post | 2015-07-02 00:50 +0200 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH 2/4] mremap: don't do mm_populate(new_addr) on failure David Rientjes <rientjes@google.com> - 2015-07-01 23:50 +0200
Re: [PATCH 2/4] mremap: don't do mm_populate(new_addr) on failure Oleg Nesterov <oleg@redhat.com> - 2015-07-02 00:50 +0200
| From | David Rientjes <rientjes@google.com> |
|---|---|
| Date | 2015-07-01 23:50 +0200 |
| Subject | Re: [PATCH 2/4] mremap: don't do mm_populate(new_addr) on failure |
| Message-ID | <pHy3h-2ew-9@gated-at.bofh.it> |
On Sat, 20 Jun 2015, Oleg Nesterov wrote:
> move_vma() sets *locked even if move_page_tables() or ->mremap()
> fails, change sys_mremap() to check "ret & ~PAGE_MASK".
>
> I think we should simply remove the VM_LOCKED code in move_vma(),
> that is why this patch doesn't change move_vma(). But this needs
> more cleanups.
>
> Signed-off-by: Oleg Nesterov <oleg@redhat.com>
> ---
> mm/mremap.c | 4 +++-
> 1 files changed, 3 insertions(+), 1 deletions(-)
>
> diff --git a/mm/mremap.c b/mm/mremap.c
> index a6306bc..492721c 100644
> --- a/mm/mremap.c
> +++ b/mm/mremap.c
> @@ -574,8 +574,10 @@ SYSCALL_DEFINE5(mremap, unsigned long, addr, unsigned long, old_len,
> ret = move_vma(vma, addr, old_len, new_len, new_addr, &locked);
> }
> out:
> - if (ret & ~PAGE_MASK)
> + if (ret & ~PAGE_MASK) {
> vm_unacct_memory(charged);
> + locked = 0;
> + }
> up_write(¤t->mm->mmap_sem);
> if (locked && new_len > old_len)
> mm_populate(new_addr + old_len, new_len - old_len);
Acked-by: David Rientjes <rientjes@google.com>
Might be cleaner to rename this to "populate" in sys_mremap() and set it
to false in the previous old_len >= new_len conditional and remove the
check here for new_len > old_len.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [next] | [standalone]
| From | Oleg Nesterov <oleg@redhat.com> |
|---|---|
| Date | 2015-07-02 00:50 +0200 |
| Message-ID | <pHyZj-2Qm-11@gated-at.bofh.it> |
| In reply to | #1175567 |
On 07/01, David Rientjes wrote:
>
> On Sat, 20 Jun 2015, Oleg Nesterov wrote:
>
> > move_vma() sets *locked even if move_page_tables() or ->mremap()
> > fails, change sys_mremap() to check "ret & ~PAGE_MASK".
> >
> > I think we should simply remove the VM_LOCKED code in move_vma(),
> > that is why this patch doesn't change move_vma(). But this needs
> > more cleanups.
> >
> > Signed-off-by: Oleg Nesterov <oleg@redhat.com>
> > ---
> > mm/mremap.c | 4 +++-
> > 1 files changed, 3 insertions(+), 1 deletions(-)
> >
> > diff --git a/mm/mremap.c b/mm/mremap.c
> > index a6306bc..492721c 100644
> > --- a/mm/mremap.c
> > +++ b/mm/mremap.c
> > @@ -574,8 +574,10 @@ SYSCALL_DEFINE5(mremap, unsigned long, addr, unsigned long, old_len,
> > ret = move_vma(vma, addr, old_len, new_len, new_addr, &locked);
> > }
> > out:
> > - if (ret & ~PAGE_MASK)
> > + if (ret & ~PAGE_MASK) {
> > vm_unacct_memory(charged);
> > + locked = 0;
> > + }
> > up_write(¤t->mm->mmap_sem);
> > if (locked && new_len > old_len)
> > mm_populate(new_addr + old_len, new_len - old_len);
>
> Acked-by: David Rientjes <rientjes@google.com>
Thanks! I am resending this series with your acks applies.
Plus another patche which was already acked but ignored anyway ;)
> Might be cleaner to rename this to "populate" in sys_mremap() and set it
> to false in the previous old_len >= new_len conditional and remove the
> check here for new_len > old_len.
Oh, this needs much more cleanups. Imo the whole VM_LOCKED logic in these
paths is ugly and confusing. move_vma() shouldn't look at VM_LOCKED at all,
mremap_to() should not duplicate the vma_to_resize/move_vma code, etc.
Oleg.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web