Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1175567

Re: [PATCH 2/4] mremap: don't do mm_populate(new_addr) on failure

From David Rientjes <rientjes@google.com>
Newsgroups linux.kernel
Subject Re: [PATCH 2/4] mremap: don't do mm_populate(new_addr) on failure
Date 2015-07-01 23:50 +0200
Message-ID <pHy3h-2ew-9@gated-at.bofh.it> (permalink)
References <pDdTr-5lS-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Sat, 20 Jun 2015, Oleg Nesterov wrote:

> move_vma() sets *locked even if move_page_tables() or ->mremap()
> fails, change sys_mremap() to check "ret & ~PAGE_MASK".
> 
> I think we should simply remove the VM_LOCKED code in move_vma(),
> that is why this patch doesn't change move_vma(). But this needs
> more cleanups.
> 
> Signed-off-by: Oleg Nesterov <oleg@redhat.com>
> ---
>  mm/mremap.c |    4 +++-
>  1 files changed, 3 insertions(+), 1 deletions(-)
> 
> diff --git a/mm/mremap.c b/mm/mremap.c
> index a6306bc..492721c 100644
> --- a/mm/mremap.c
> +++ b/mm/mremap.c
> @@ -574,8 +574,10 @@ SYSCALL_DEFINE5(mremap, unsigned long, addr, unsigned long, old_len,
>  		ret = move_vma(vma, addr, old_len, new_len, new_addr, &locked);
>  	}
>  out:
> -	if (ret & ~PAGE_MASK)
> +	if (ret & ~PAGE_MASK) {
>  		vm_unacct_memory(charged);
> +		locked = 0;
> +	}
>  	up_write(&current->mm->mmap_sem);
>  	if (locked && new_len > old_len)
>  		mm_populate(new_addr + old_len, new_len - old_len);

Acked-by: David Rientjes <rientjes@google.com>

Might be cleaner to rename this to "populate" in sys_mremap() and set it 
to false in the previous old_len >= new_len conditional and remove the 
check here for new_len > old_len.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread


Thread

Re: [PATCH 2/4] mremap: don't do mm_populate(new_addr) on failure David Rientjes <rientjes@google.com> - 2015-07-01 23:50 +0200
  Re: [PATCH 2/4] mremap: don't do mm_populate(new_addr) on failure Oleg Nesterov <oleg@redhat.com> - 2015-07-02 00:50 +0200

csiph-web