Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1166378 > unrolled thread
| Started by | "H. Peter Anvin" <hpa@zytor.com> |
|---|---|
| First post | 2015-06-16 22:30 +0200 |
| Last post | 2015-06-19 09:20 +0200 |
| Articles | 3 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [tip:x86/asm] x86/asm/entry: (Re-) rename __NR_entry_INT80_compat_max to __NR_syscall_compat_max "H. Peter Anvin" <hpa@zytor.com> - 2015-06-16 22:30 +0200
Re: [RFC] Rename various 'IA32' uses in arch/x86/ code Ingo Molnar <mingo@kernel.org> - 2015-06-19 09:10 +0200
Re: [RFC] Rename various 'IA32' uses in arch/x86/ code Ingo Molnar <mingo@kernel.org> - 2015-06-19 09:20 +0200
| From | "H. Peter Anvin" <hpa@zytor.com> |
|---|---|
| Date | 2015-06-16 22:30 +0200 |
| Subject | Re: [tip:x86/asm] x86/asm/entry: (Re-) rename __NR_entry_INT80_compat_max to __NR_syscall_compat_max |
| Message-ID | <pC5EB-4Oe-11@gated-at.bofh.it> |
On 06/08/2015 03:24 PM, tip-bot for Ingo Molnar wrote:
> Commit-ID: bace7117d3fb59a6ed7ea1aa6c8994df6a28a72a
> Gitweb: http://git.kernel.org/tip/bace7117d3fb59a6ed7ea1aa6c8994df6a28a72a
> Author: Ingo Molnar <mingo@kernel.org>
> AuthorDate: Mon, 8 Jun 2015 21:20:26 +0200
> Committer: Ingo Molnar <mingo@kernel.org>
> CommitDate: Mon, 8 Jun 2015 23:43:38 +0200
>
> x86/asm/entry: (Re-)rename __NR_entry_INT80_compat_max to __NR_syscall_compat_max
>
> Brian Gerst noticed that I did a weird rename in the following commit:
>
> b2502b418e63 ("x86/asm/entry: Untangle 'system_call' into two entry points: entry_SYSCALL_64 and entry_INT80_32")
>
> which renamed __NR_ia32_syscall_max to __NR_entry_INT80_compat_max.
>
> Now the original name was a misnomer, but the new one is a misnomer as well,
> as all the 32-bit compat syscall entry points (sysenter, syscall) share the
> system call table, not just the INT80 based one.
>
> Rename it to __NR_syscall_compat_max.
>
The original one wasn't really a misnomer, as it referred to the ia32
system calls specifically, but this works too.
-hpa
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[toc] | [next] | [standalone]
| From | Ingo Molnar <mingo@kernel.org> |
|---|---|
| Date | 2015-06-19 09:10 +0200 |
| Subject | Re: [RFC] Rename various 'IA32' uses in arch/x86/ code |
| Message-ID | <pCYB4-d4-17@gated-at.bofh.it> |
| In reply to | #1166378 |
* Brian Gerst <brgerst@gmail.com> wrote: > > Ok, so your goal is to allow the x32 ABI, but not 32-bit user-space? > > It just seems odd that x32 (which is really a 64-bit ABI with 32-bit pointers) > depended on enabling 32-bit support. Other than both using the core compat > code, they are not really related. Yeah. > > I suppose that makes some sense, it might be a valid 'attack surface > > reduction' technique, while still allowing the x32 ABI. > > > > But I'm not sure we should bother and complicate things: 32-bit compat isn't > > going away anytime soon, and most of CONFIG_COMPAT is needed for x32. > > Many of the compat syscalls are unused by x32. It only needs to handle syscalls > with pointers embedded in data structures differently than native 64-bit. Yeah, but in fact those are the 'most interesting' (read: most complex) aspects of the generic compat machinery. So most of the 'core compat' functionality is used - even though we don't use many of the (trivial) argument-converted syscall variants. > 64-bit integer arguments (ie., loff_t) do not need special handling, since they > can be passed in a single register instead of a pair of 32-bit registers. This > won't solve that particular issue yet, but it's something to be aware of for > future cleanups. Yes, and I think 'X32' is a misnomer in that sense: in reality it's a 90% 64-bit ABI that just happens to have a handful of additional system calls that can deal with data pointers truncated to 32 bits. So 'C64' would have been a better name: a compacted 64-bit ABI - but that particular name has its own problems ;-) Maybe S64 (small 64-bit memory model)? 'S64' would also have been an easier sell to distros: they generally resist adding anything that smells old, 32-bit ... but kernel hackers and marketing were always somewhat disjunct sets ;-) I'm wondering whether we'll ever see a 48-bit user-space pointer model ;-) They are misaligned by 32 bits, but x86 CPUs generally handle 32-bit misalignment just fine. The killer would be to zero-extend from 48 bits to 64 bits I suspect - there's no natural instruction for that. > > So maybe we could introduce CONFIG_X86_32_ABI=y or so, which would cover just > > the 32-bit entry code and the signal frame compatibility layer? > > Yes. Ok, then it sounds good to me! Thanks, Ingo -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [next] | [standalone]
| From | Ingo Molnar <mingo@kernel.org> |
|---|---|
| Date | 2015-06-19 09:20 +0200 |
| Subject | Re: [RFC] Rename various 'IA32' uses in arch/x86/ code |
| Message-ID | <pCYKJ-oj-5@gated-at.bofh.it> |
| In reply to | #1166378 |
* H. Peter Anvin <hpa@zytor.com> wrote: > We have generally used i386 as opposed to x86 for that purpose. [...] So 'i386' is really the original name that stuck. 'x86-32' sounds more appropriate to me - we should not perpetuate the i386 name, as we don't run on an original i386 anymore ;-) Here's what I think sounds pretty natural: CONFIG_X86_32_ABI CONFIG_X86_64_ABI CONFIG_X86_X32_ABI - CONFIG_X86_X32_ABI and CONFIG_X86_32_ABI selects CONFIG_COMPAT. - CONFIG_X86_32_ABI enables the 32-bit/32-bit system call ABI. - CONFIG_X86_X32_ABI enables the extra 64-bit/32-bit system call entries. - CONFIG_IA32_EMULATION goes away. > [...] IA32 in MSR names is part of the MSR name and should not be taken out. Yes, of course. Thanks, Ingo -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web