Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1166378

Re: [tip:x86/asm] x86/asm/entry: (Re-) rename __NR_entry_INT80_compat_max to __NR_syscall_compat_max

From "H. Peter Anvin" <hpa@zytor.com>
Newsgroups linux.kernel
Subject Re: [tip:x86/asm] x86/asm/entry: (Re-) rename __NR_entry_INT80_compat_max to __NR_syscall_compat_max
Date 2015-06-16 22:30 +0200
Message-ID <pC5EB-4Oe-11@gated-at.bofh.it> (permalink)
References <pC5EB-4Oe-13@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 06/08/2015 03:24 PM, tip-bot for Ingo Molnar wrote:
> Commit-ID:  bace7117d3fb59a6ed7ea1aa6c8994df6a28a72a
> Gitweb:     http://git.kernel.org/tip/bace7117d3fb59a6ed7ea1aa6c8994df6a28a72a
> Author:     Ingo Molnar <mingo@kernel.org>
> AuthorDate: Mon, 8 Jun 2015 21:20:26 +0200
> Committer:  Ingo Molnar <mingo@kernel.org>
> CommitDate: Mon, 8 Jun 2015 23:43:38 +0200
> 
> x86/asm/entry: (Re-)rename __NR_entry_INT80_compat_max to __NR_syscall_compat_max
> 
> Brian Gerst noticed that I did a weird rename in the following commit:
> 
>    b2502b418e63 ("x86/asm/entry: Untangle 'system_call' into two entry points: entry_SYSCALL_64 and entry_INT80_32")
> 
> which renamed __NR_ia32_syscall_max to __NR_entry_INT80_compat_max.
> 
> Now the original name was a misnomer, but the new one is a misnomer as well,
> as all the 32-bit compat syscall entry points (sysenter, syscall) share the
> system call table, not just the INT80 based one.
> 
> Rename it to __NR_syscall_compat_max.
> 

The original one wasn't really a misnomer, as it referred to the ia32
system calls specifically, but this works too.

	-hpa


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

Re: [tip:x86/asm] x86/asm/entry: (Re-) rename __NR_entry_INT80_compat_max  to __NR_syscall_compat_max "H. Peter Anvin" <hpa@zytor.com> - 2015-06-16 22:30 +0200
  Re: [RFC] Rename various 'IA32' uses in arch/x86/ code Ingo Molnar <mingo@kernel.org> - 2015-06-19 09:10 +0200
  Re: [RFC] Rename various 'IA32' uses in arch/x86/ code Ingo Molnar <mingo@kernel.org> - 2015-06-19 09:20 +0200

csiph-web