Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1738611
| From | Sinan Kaya <okaya@codeaurora.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 3/5] PCI: make pci_flr_wait() generic and rename to pci_dev_wait() |
| Date | 2017-09-25 02:40 +0200 |
| Message-ID | <utpBg-7cZ-9@gated-at.bofh.it> (permalink) |
| References | <ut2Ol-1AW-3@gated-at.bofh.it> <ut2Ol-1AW-5@gated-at.bofh.it> <utePv-EY-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 9/24/2017 9:08 AM, Christoph Hellwig wrote: > On Sat, Sep 23, 2017 at 08:16:56PM -0400, Sinan Kaya wrote: >> Rev 3.1 Sec 2.3.1 Request Handling Rules: >> Valid reset conditions after which a device is permitted to return CRS >> are: >> * Cold, Warm, and Hot Resets, >> * FLR >> * A reset initiated in response to a D3hot to D0 uninitialized >> >> Try to reuse FLR implementation towards other reset types. > > Maybe call it pci_reset_wait instead of pci_dev_wait? > I can go for pci_dev_reset_wait(). I was using the PCI directory function naming nomenclature where some functions using struct pci_dev start with pci_dev and others using struct pci_bus start with pci_bus. -- Sinan Kaya Qualcomm Datacenter Technologies, Inc. as an affiliate of Qualcomm Technologies, Inc. Qualcomm Technologies, Inc. is a member of the Code Aurora Forum, a Linux Foundation Collaborative Project.
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 3/5] PCI: make pci_flr_wait() generic and rename to pci_dev_wait() Sinan Kaya <okaya@codeaurora.org> - 2017-09-24 02:20 +0200
Re: [PATCH 3/5] PCI: make pci_flr_wait() generic and rename to pci_dev_wait() Christoph Hellwig <hch@infradead.org> - 2017-09-24 15:10 +0200
Re: [PATCH 3/5] PCI: make pci_flr_wait() generic and rename to pci_dev_wait() Sinan Kaya <okaya@codeaurora.org> - 2017-09-25 02:40 +0200
csiph-web