Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1738182

Re: [PATCH 3/5] PCI: make pci_flr_wait() generic and rename to pci_dev_wait()

From Christoph Hellwig <hch@infradead.org>
Newsgroups linux.kernel
Subject Re: [PATCH 3/5] PCI: make pci_flr_wait() generic and rename to pci_dev_wait()
Date 2017-09-24 15:10 +0200
Message-ID <utePv-EY-7@gated-at.bofh.it> (permalink)
References <ut2Ol-1AW-3@gated-at.bofh.it> <ut2Ol-1AW-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Sat, Sep 23, 2017 at 08:16:56PM -0400, Sinan Kaya wrote:
> Rev 3.1 Sec 2.3.1 Request Handling Rules:
> Valid reset conditions after which a device is permitted to return CRS
> are:
> * Cold, Warm, and Hot Resets,
> * FLR
> * A reset initiated in response to a D3hot to D0 uninitialized
> 
> Try to reuse FLR implementation towards other reset types.

Maybe call it pci_reset_wait instead of pci_dev_wait?

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 3/5] PCI: make pci_flr_wait() generic and rename to pci_dev_wait() Sinan Kaya <okaya@codeaurora.org> - 2017-09-24 02:20 +0200
  Re: [PATCH 3/5] PCI: make pci_flr_wait() generic and rename to  pci_dev_wait() Christoph Hellwig <hch@infradead.org> - 2017-09-24 15:10 +0200
    Re: [PATCH 3/5] PCI: make pci_flr_wait() generic and rename to  pci_dev_wait() Sinan Kaya <okaya@codeaurora.org> - 2017-09-25 02:40 +0200

csiph-web