Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1739542

Re: [PATCH 5/7] xfs: introduce xfs_is_dax_state_changing

Path csiph.com!news.redatomik.org!news.albasani.net!news.mixmin.net!news.unit0.net!news.panservice.it!bofh.it!news.nic.it!robomod
From Christoph Hellwig <hch@lst.de>
Newsgroups linux.kernel
Subject Re: [PATCH 5/7] xfs: introduce xfs_is_dax_state_changing
Date Tue, 26 Sep 2017 08:40:02 +0200
Message-ID <utRHc-10R-9@gated-at.bofh.it> (permalink)
References <utKPp-4Lc-5@gated-at.bofh.it> <utKPp-4Lc-21@gated-at.bofh.it>
MIME-Version 1.0
Content-Type text/plain; charset=us-ascii
Content-Disposition inline
User-Agent Mutt/1.5.17 (2007-11-01)
Sender robomod@news.nic.it
List-ID <linux-kernel.vger.kernel.org>
X-Mailing-List linux-kernel@vger.kernel.org
Approved robomod@news.nic.it
Lines 8
Organization linux.* mail to news gateway
X-Original-Cc Andrew Morton <akpm@linux-foundation.org>, linux-kernel@vger.kernel.org, "Darrick J. Wong" <darrick.wong@oracle.com>, "J. Bruce Fields" <bfields@fieldses.org>, Christoph Hellwig <hch@lst.de>, Dan Williams <dan.j.williams@intel.com>, Dave Chinner <david@fromorbit.com>, Jan Kara <jack@suse.cz>, Jeff Layton <jlayton@poochiereds.net>, linux-fsdevel@vger.kernel.org, linux-mm@kvack.org, linux-nvdimm@lists.01.org, linux-xfs@vger.kernel.org
X-Original-Date Tue, 26 Sep 2017 08:33:14 +0200
X-Original-Message-ID <20170926063314.GB6870@lst.de>
X-Original-References <20170925231404.32723-1-ross.zwisler@linux.intel.com> <20170925231404.32723-6-ross.zwisler@linux.intel.com>
X-Original-Sender linux-kernel-owner@vger.kernel.org
Xref csiph.com linux.kernel:1739542

Show key headers only | View raw


> +static bool
> +xfs_is_dax_state_changing(
> +	unsigned int		xflags,
> +	struct xfs_inode	*ip)

And I have no fricking idea what 'is_dax_state_changing' is supposed
to mean for the caller.  This needs a better name and/or a comment
explaining the function.

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH 5/7] xfs: introduce xfs_is_dax_state_changing Ross Zwisler <ross.zwisler@linux.intel.com> - 2017-09-26 01:20 +0200
  Re: [PATCH 5/7] xfs: introduce xfs_is_dax_state_changing Christoph Hellwig <hch@lst.de> - 2017-09-26 08:40 +0200

csiph-web