Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1736337

Re: [PATCH] block: consider merge of segments when merge bio into rq

From "jianchao.wang" <jianchao.w.wang@oracle.com>
Newsgroups linux.kernel
Subject Re: [PATCH] block: consider merge of segments when merge bio into rq
Date 2017-09-21 04:50 +0200
Message-ID <urZIS-3fm-3@gated-at.bofh.it> (permalink)
References <upTex-833-7@gated-at.bofh.it> <urYtr-2rF-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw



On 09/21/2017 09:29 AM, Christoph Hellwig wrote:
> So the check change here looks good to me.
> 
> I don't like like the duplicate code, can you look into sharing
> the new segment checks between the two functions and the existing
> instance in ll_merge_requests_fn by passing say two struct bio *bio1
> and struct bio *bio2 pointer instead of using req->bio and req->biotail?
> 
> Also please include the information that you posted in the reply to
> the other patch in the description for this one.
> 
I have looked into the ll_back/front_merge_fn() and ll_merge_requests_fn().
It seems that segments check code fragment looks similar but not unified.
We could unify the part of calculation of variable of seg_size and contig,
but not the positions where use these two.
Especially the calculation of total_phys_segments and judgment of 
'nr_phys_segments == 1', rq variable cannot be avoided there. And the update
of bi_seg_front/back_size is also very tricky. If force to merge these code 
fragments together, the code may become hard to read.

So please refer to the V2 patch which contain more comment about the issue
and result.

Thanks
Jianchao

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH] block: consider merge of segments when merge bio into rq Jianchao Wang <jianchao.w.wang@oracle.com> - 2017-09-15 09:30 +0200
  Re: [PATCH] block: consider merge of segments when merge bio into rq Christoph Hellwig <hch@infradead.org> - 2017-09-21 03:30 +0200
    Re: [PATCH] block: consider merge of segments when merge bio into rq "jianchao.wang" <jianchao.w.wang@oracle.com> - 2017-09-21 03:40 +0200
    Re: [PATCH] block: consider merge of segments when merge bio into rq "jianchao.wang" <jianchao.w.wang@oracle.com> - 2017-09-21 04:50 +0200

csiph-web