Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1736320
| From | "jianchao.wang" <jianchao.w.wang@oracle.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] block: consider merge of segments when merge bio into rq |
| Date | 2017-09-21 03:40 +0200 |
| Message-ID | <urYD7-2va-3@gated-at.bofh.it> (permalink) |
| References | <upTex-833-7@gated-at.bofh.it> <urYtr-2rF-9@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 09/21/2017 09:29 AM, Christoph Hellwig wrote: > So the check change here looks good to me. > > I don't like like the duplicate code, can you look into sharing > the new segment checks between the two functions and the existing > instance in ll_merge_requests_fn by passing say two struct bio *bio1 > and struct bio *bio2 pointer instead of using req->bio and req->biotail? > > Also please include the information that you posted in the reply to > the other patch in the description for this one. > I have just sent a new version which contains more comment before I see this mail. I will send out another new version that apply your advice later. Thanks for your kind and fair comment. Jianchao
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] block: consider merge of segments when merge bio into rq Jianchao Wang <jianchao.w.wang@oracle.com> - 2017-09-15 09:30 +0200
Re: [PATCH] block: consider merge of segments when merge bio into rq Christoph Hellwig <hch@infradead.org> - 2017-09-21 03:30 +0200
Re: [PATCH] block: consider merge of segments when merge bio into rq "jianchao.wang" <jianchao.w.wang@oracle.com> - 2017-09-21 03:40 +0200
Re: [PATCH] block: consider merge of segments when merge bio into rq "jianchao.wang" <jianchao.w.wang@oracle.com> - 2017-09-21 04:50 +0200
csiph-web