Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1726268
| Path | csiph.com!news.freedyn.net!open-news-network.org!aioe.org!bofh.it!news.nic.it!robomod |
|---|---|
| From | "Rafael J. Wysocki" <rafael@kernel.org> |
| Newsgroups | linux.kernel |
| Subject | [GIT PULL] Device properties framework updates for v4.14-rc1 |
| Date | Mon, 04 Sep 2017 23:50:02 +0200 |
| Message-ID | <um7pM-2lb-9@gated-at.bofh.it> (permalink) |
| Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20161025; h=mime-version:sender:from:date:message-id:subject:to:cc; bh=W0pbb5zFYw5BH3qzfNaFSnlbKikVT92S5ENCvlDphiE=; b=BDb1hFyV7daJoW0jMBfzuuBlB1prZs9bAYg2XNBolJ+EeTN3F1E03gKSAIEzt2vV6m PeIaOHyzIAYznP+OBZlNs/zz5bEuICYdyqZKmm3dLJP16MgBlh/+m91xXx0yaahjJmvI UMzxNFyKfjWvQoIMGytzLqg/+KgosuSl40gCbg7qK+HHohTxFagjAAy8Gv84WScVu8jp wEegKZgrN1AW/wsktcHB52Rofrg6L5GAe0r/lhb7rPvXnJUfLmSDNqXyxb/WbRDyAc1n ATu0cRfLMjk0nlc4nC4VIsJmC3japwzQPBvjl+dPvBjGMEJguk34NPAsKUIrfCNdjdir AutQ== |
| X-Google-Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:mime-version:sender:from:date:message-id:subject :to:cc; bh=W0pbb5zFYw5BH3qzfNaFSnlbKikVT92S5ENCvlDphiE=; b=CBv/KFmULgGHn15q8y36fmxP185BqiQDkg0epVyuz23e8C4eQowT6Ulm8WiNV8qZgj VT5EqsWfySTRiLRtBEzrUpef9QmPfTb75WPird4+1g1YVxE0SsL1yUkYKx/bgFuA6YFE nVSPCGVphv85Knnl5rgJpamS8vRoPW2GGd0dgT6JuUkELvp8HtqL9f9ymiacIY7ApJ/Z IKHfx0Htx8m0uu99asQME3FKp9/v4NIbQx7hQ6M2CbHTeOHvF6BzoCrG1D3Gd1/5Pl7Y lUMd1WI6H2oUjmlgmWn8dfcNxaj8Et3PqAuPvvNV6jCuD8ncLhmP2QG3+GqlnQGAEveV xNtA== |
| X-Gm-Message-State | AHPjjUjq8yK6Hw8k2PUYjux++9G8QpBxKmTtSdIVz8ZKnniCsXgaWfEp QzpDiOPxQB78Exra0nVvhxXea93OEBND |
| X-Google-SMTP-Source | ADKCNb5xust5MalxJh3AX6o9HENaqJHHo24FAN/7iMcVl/4yNkhvghm87ctsLAs7pnUvAVuEa0/g17J03/eLSRXNlOk= |
| X-Received | by 10.202.102.144 with SMTP id m16mr1717569oik.194.1504561269497; Mon, 04 Sep 2017 14:41:09 -0700 (PDT) |
| MIME-Version | 1.0 |
| X-Google-Sender-Auth | RTCnRUWHK99xrKmuFlaJs3jj1XQ |
| Content-Type | text/plain; charset="UTF-8" |
| Sender | robomod@news.nic.it |
| List-ID | <linux-kernel.vger.kernel.org> |
| X-Mailing-List | linux-kernel@vger.kernel.org |
| Approved | robomod@news.nic.it |
| Lines | 75 |
| Organization | linux.* mail to news gateway |
| X-Original-Cc | ACPI Devel Maling List <linux-acpi@vger.kernel.org>, Linux Kernel Mailing List <linux-kernel@vger.kernel.org> |
| X-Original-Date | Mon, 4 Sep 2017 23:41:09 +0200 |
| X-Original-Message-ID | <CAJZ5v0iJoeVMPxknHirWC0=AeVpGQE-Np+s+QwZc3GhgHp1jOg@mail.gmail.com> |
| X-Original-Sender | linux-kernel-owner@vger.kernel.org |
| Xref | csiph.com linux.kernel:1726268 |
Show key headers only | View raw
Hi Linus,
Please pull from the tag
git://git.kernel.org/pub/scm/linux/kernel/git/rafael/linux-pm.git \
devprop-4.14-rc1
with top-most commit 3689d3d6907271b5737de5bff584cb50cb29ebc2
ACPI: device property: Switch to use new generic UUID API
on top of commit 5771a8c08880cdca3bfb4a3fc6d309d6bba20877
Linux v4.13-rc1
to receive device properties framework updates for v4.14-rc1.
These introduce fwnode operations for all of the separate types of
"firmware nodes" that can be handled by the device properties
framework, make the framework use const fwnode arguments all over,
add a helper for the consolidated handling of node references
and switch over the framework to the new UUID API.
Specifics:
- Introduce fwnode operations for all of the separate types of
"firmware nodes" that can be handled by the device properties
framework and drop the type field from struct fwnode_handle
(Sakari Ailus, Arnd Bergmann).
- Make the device properties framework use const fwnode arguments
where possible (Sakari Ailus).
- Add a helper for the consolidated handling of node references
to the device properties framework (Sakari Ailus).
- Switch over the ACPI part of the device properties framework
to the new UUID API (Andy Shevchenko).
Thanks!
---------------
Andy Shevchenko (1):
ACPI: device property: Switch to use new generic UUID API
Arnd Bergmann (1):
device property: export irqchip_fwnode_ops
Sakari Ailus (8):
ACPI: Use IS_ERR_OR_NULL() instead of non-NULL check in
is_acpi_data_node()
device property: Get rid of struct fwnode_handle type field
ACPI: Prepare for constifying acpi_get_next_subnode() fwnode argument
ACPI: Constify acpi_bus helper functions, switch to macros
ACPI: Constify internal fwnode arguments
device property: Constify argument to pset fwnode backend
device property: Constify fwnode property API
device property: Introduce fwnode_property_get_reference_args
---------------
drivers/acpi/property.c | 231 ++++++++++++++++++++++++++++------------------
drivers/acpi/scan.c | 3 +-
drivers/base/property.c | 131 +++++++++++++++++---------
drivers/of/property.c | 66 +++++++++----
include/acpi/acpi_bus.h | 52 +++++++----
include/linux/acpi.h | 68 +++++++-------
include/linux/fwnode.h | 56 ++++++-----
include/linux/irqdomain.h | 4 +-
include/linux/of.h | 3 +-
include/linux/property.h | 67 ++++++++------
kernel/irq/irqdomain.c | 11 ++-
11 files changed, 428 insertions(+), 264 deletions(-)
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
[GIT PULL] Device properties framework updates for v4.14-rc1 "Rafael J. Wysocki" <rafael@kernel.org> - 2017-09-04 23:50 +0200
csiph-web