Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1726268

[GIT PULL] Device properties framework updates for v4.14-rc1

From "Rafael J. Wysocki" <rafael@kernel.org>
Newsgroups linux.kernel
Subject [GIT PULL] Device properties framework updates for v4.14-rc1
Date 2017-09-04 23:50 +0200
Message-ID <um7pM-2lb-9@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


Hi Linus,

Please pull from the tag

 git://git.kernel.org/pub/scm/linux/kernel/git/rafael/linux-pm.git \
 devprop-4.14-rc1

with top-most commit 3689d3d6907271b5737de5bff584cb50cb29ebc2

 ACPI: device property: Switch to use new generic UUID API

on top of commit 5771a8c08880cdca3bfb4a3fc6d309d6bba20877

 Linux v4.13-rc1

to receive device properties framework updates for v4.14-rc1.

These introduce fwnode operations for all of the separate types of
"firmware nodes" that can be handled by the device properties
framework, make the framework use const fwnode arguments all over,
add a helper for the consolidated handling of node references
and switch over the framework to the new UUID API.

Specifics:

 - Introduce fwnode operations for all of the separate types of
   "firmware nodes" that can be handled by the device properties
   framework and drop the type field from struct fwnode_handle
   (Sakari Ailus, Arnd Bergmann).

 - Make the device properties framework use const fwnode arguments
   where possible (Sakari Ailus).

 - Add a helper for the consolidated handling of node references
   to the device properties framework (Sakari Ailus).

 - Switch over the ACPI part of the device properties framework
   to the new UUID API (Andy Shevchenko).

Thanks!


---------------

Andy Shevchenko (1):
      ACPI: device property: Switch to use new generic UUID API

Arnd Bergmann (1):
      device property: export irqchip_fwnode_ops

Sakari Ailus (8):
      ACPI: Use IS_ERR_OR_NULL() instead of non-NULL check in
is_acpi_data_node()
      device property: Get rid of struct fwnode_handle type field
      ACPI: Prepare for constifying acpi_get_next_subnode() fwnode argument
      ACPI: Constify acpi_bus helper functions, switch to macros
      ACPI: Constify internal fwnode arguments
      device property: Constify argument to pset fwnode backend
      device property: Constify fwnode property API
      device property: Introduce fwnode_property_get_reference_args

---------------

 drivers/acpi/property.c   | 231 ++++++++++++++++++++++++++++------------------
 drivers/acpi/scan.c       |   3 +-
 drivers/base/property.c   | 131 +++++++++++++++++---------
 drivers/of/property.c     |  66 +++++++++----
 include/acpi/acpi_bus.h   |  52 +++++++----
 include/linux/acpi.h      |  68 +++++++-------
 include/linux/fwnode.h    |  56 ++++++-----
 include/linux/irqdomain.h |   4 +-
 include/linux/of.h        |   3 +-
 include/linux/property.h  |  67 ++++++++------
 kernel/irq/irqdomain.c    |  11 ++-
 11 files changed, 428 insertions(+), 264 deletions(-)

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

[GIT PULL] Device properties framework updates for v4.14-rc1 "Rafael J. Wysocki" <rafael@kernel.org> - 2017-09-04 23:50 +0200

csiph-web