Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1723654
| From | Pavel Machek <pavel@ucw.cz> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v6 1/2] platform: Add driver for RAVE Supervisory Processor |
| Date | 2017-08-30 22:40 +0200 |
| Message-ID | <ukhWi-4BB-7@gated-at.bofh.it> (permalink) |
| References | <ujveV-7TT-9@gated-at.bofh.it> <ujveW-7TT-23@gated-at.bofh.it> <uk8T0-7g3-11@gated-at.bofh.it> <ukgxb-3Pz-9@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
[Multipart message — attachments visible in raw view] - view raw
Hi!
> >> + * 9 -> Illegal Trap
> >> + * 10 -> Unknown
> >> + * 11 -> Crew Panel Requested
> >
> > Anyway... If you move management chip to .. I don't know, i2c, the
> > path would change. Also it would be different path on N900. Userland
> > should not have to deal with this.
> >
> > And... this should really be string, as the list will need to grow on
> > different hardware.
>
> I think we have a misunderstanding, with this part of the patch set I
> am not trying to propose a generic ABI that would be useful for any
> other driver but this one. Hence the lack of concern for different
Yes, but sorry, that's no-go. Kernel should hide differences between
different machiens, and it should be rather easy in this case.
> hardware paths (it's not going to change for this device) and device
> specific codes instead of generic strings. I can see how my choice of
> generic name such as "reset_reason" might suggest that, so I apologize
> for any confusion I might have caused. If said generic name is
> unacceptable I can change it to "rave_reset_reason" or something
> similar and if that is undesirable as well I am happy to drop this
> part of the patch and re-visit this later.
Ok, can we do the re-visit thing? You may want to contact these people:
Date: Wed, 30 Aug 2017 12:59:55 +0200
From: Pavel Machek <pavel@ucw.cz>
To: Vadim Pasternak <vadimp@mellanox.com>
Cc: lee.jones@linaro.org, robh+dt@kernel.org,
devicetree@vger.kernel.org,
j.anaszewski@samsung.com, rpurdie@rpsys.net,
linux-leds@vger.kernel.org,
jiri@resnulli.us, gregkh@linuxfoundation.org,
platform-driver-x86@vger.kernel.org
Subject: Re: [patch v4 1/2] mfd: Add Mellanox regmap core driver
They are currently trying to add driver, including
> Cause of reset nodes:
> - cpu_kernel_panic
> - cpu_shutdown
> - bmc_warm_reset
...which sounds very similar to what you are doing.
> > Plus we'll really need better explanations. What is difference between
> > "normal power off" and "host requested"?
> >
>
> Short answer: I don't know, since this is as much information that ICD
> for that device gave me.
>
> Long answer: It probably can be discerned from the source code of the
> firmware/schematic as well as by bothering the right people, but since
> I get a feeling that this attribute is not really desirable in its
> current from, I'll punt doing that.
Ok.
> >> + The following values are valid:
> >> + * 0 -> SD card
> >> + * 1 -> eMMC
> >> + * 2 -> SPI NOR
> >> +
> >> + NOTE: Setting boot source on RDU1 hardware is
> >> + currently not implemented
> >
> > Same comments apply here.
>
> Yep, same comment for me as well :-)
Ok :-).
Best regards,
Pavel
--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v6 0/2] ZII RAVE platform driver Andrey Smirnov <andrew.smirnov@gmail.com> - 2017-08-28 18:40 +0200
Re: [PATCH v6 1/2] platform: Add driver for RAVE Supervisory Processor Pavel Machek <pavel@ucw.cz> - 2017-08-30 13:00 +0200
Re: [PATCH v6 1/2] platform: Add driver for RAVE Supervisory Processor Andrey Smirnov <andrew.smirnov@gmail.com> - 2017-08-30 21:10 +0200
Re: [PATCH v6 1/2] platform: Add driver for RAVE Supervisory Processor Pavel Machek <pavel@ucw.cz> - 2017-08-30 22:40 +0200
Re: [PATCH v6 1/2] platform: Add driver for RAVE Supervisory Processor Pavel Machek <pavel@ucw.cz> - 2017-08-31 10:20 +0200
Re: [PATCH v6 1/2] platform: Add driver for RAVE Supervisory Processor Nikita Yushchenko <nikita.yoush@cogentembedded.com> - 2017-08-31 11:10 +0200
Re: [PATCH v6 1/2] platform: Add driver for RAVE Supervisory Processor Pavel Machek <pavel@ucw.cz> - 2017-08-31 11:20 +0200
Re: [PATCH v6 1/2] platform: Add driver for RAVE Supervisory Processor Nikita Yushchenko <nikita.yoush@cogentembedded.com> - 2017-08-31 10:20 +0200
Re: [PATCH v6 1/2] platform: Add driver for RAVE Supervisory Processor Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2017-08-31 18:50 +0200
csiph-web