Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1710592

Re: [PATCH v6 4/7] mm: refactoring TLB gathering API

Path csiph.com!news.mixmin.net!aioe.org!bofh.it!news.nic.it!robomod
From Minchan Kim <minchan@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH v6 4/7] mm: refactoring TLB gathering API
Date Mon, 14 Aug 2017 02:50:01 +0200
Message-ID <uebJT-5EW-3@gated-at.bofh.it> (permalink)
References <u9Wq6-6U6-5@gated-at.bofh.it> <u9Wq7-6U6-27@gated-at.bofh.it> <udeqt-1IZ-9@gated-at.bofh.it> <udlLj-6j5-3@gated-at.bofh.it>
X-Original-To Nadav Amit <nadav.amit@gmail.com>
X-Original-Senderip 156.147.1.126
X-Original-Mailfrom minchan@kernel.org
X-Original-Senderip 10.177.220.163
X-Original-Mailfrom minchan@kernel.org
MIME-Version 1.0
Content-Type text/plain; charset=utf-8
Content-Disposition inline
Content-Transfer-Encoding 8bit
User-Agent Mutt/1.5.24 (2015-08-30)
Sender robomod@news.nic.it
List-ID <linux-kernel.vger.kernel.org>
X-Mailing-List linux-kernel@vger.kernel.org
Approved robomod@news.nic.it
Lines 22
Organization linux.* mail to news gateway
X-Original-Cc Peter Zijlstra <peterz@infradead.org>, "open list:MEMORY MANAGEMENT" <linux-mm@kvack.org>, LKML <linux-kernel@vger.kernel.org>, Andrew Morton <akpm@linux-foundation.org>, Ingo Molnar <mingo@redhat.com>, Russell King <linux@armlinux.org.uk>, Tony Luck <tony.luck@intel.com>, Martin Schwidefsky <schwidefsky@de.ibm.com>, "David S. Miller" <davem@davemloft.net>, Heiko Carstens <heiko.carstens@de.ibm.com>, Yoshinori Sato <ysato@users.sourceforge.jp>, Jeff Dike <jdike@addtoit.com>, linux-arch@vger.kernel.org, Mel Gorman <mgorman@techsingularity.net>
X-Original-Date Mon, 14 Aug 2017 09:49:10 +0900
X-Original-Message-ID <20170814004910.GA25427@bbox>
X-Original-References <20170802000818.4760-1-namit@vmware.com> <20170802000818.4760-5-namit@vmware.com> <20170811092334.rmeazkklvordrmrl@hirez.programming.kicks-ass.net> <EBBFF419-4E4C-440A-853B-25FB6F0DE7F6@gmail.com>
X-Original-Sender linux-kernel-owner@vger.kernel.org
Xref csiph.com linux.kernel:1710592

Show key headers only | View raw


On Fri, Aug 11, 2017 at 10:12:45AM -0700, Nadav Amit wrote:
> Peter Zijlstra <peterz@infradead.org> wrote:
> 
> > On Tue, Aug 01, 2017 at 05:08:15PM -0700, Nadav Amit wrote:
> >> From: Minchan Kim <minchan@kernel.org>
> >> 
> >> This patch is a preparatory patch for solving race problems caused by
> >> TLB batch.  For that, we will increase/decrease TLB flush pending count
> >> of mm_struct whenever tlb_[gather|finish]_mmu is called.
> >> 
> >> Before making it simple, this patch separates architecture specific
> >> part and rename it to arch_tlb_[gather|finish]_mmu and generic part
> >> just calls it.
> > 
> > I absolutely hate this. We should unify this stuff, not diverge it
> > further.
> 
> Agreed, but I don’t see how this patch makes the situation any worse.

Agree with Nadav. I don't think this patch makes things diverge further.
Peter, If you are strong against of it, please tell us what part you
are hating.

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

Re: [PATCH v6 4/7] mm: refactoring TLB gathering API Minchan Kim <minchan@kernel.org> - 2017-08-14 02:50 +0200

csiph-web