Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1710592

Re: [PATCH v6 4/7] mm: refactoring TLB gathering API

From Minchan Kim <minchan@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH v6 4/7] mm: refactoring TLB gathering API
Date 2017-08-14 02:50 +0200
Message-ID <uebJT-5EW-3@gated-at.bofh.it> (permalink)
References <u9Wq6-6U6-5@gated-at.bofh.it> <u9Wq7-6U6-27@gated-at.bofh.it> <udeqt-1IZ-9@gated-at.bofh.it> <udlLj-6j5-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, Aug 11, 2017 at 10:12:45AM -0700, Nadav Amit wrote:
> Peter Zijlstra <peterz@infradead.org> wrote:
> 
> > On Tue, Aug 01, 2017 at 05:08:15PM -0700, Nadav Amit wrote:
> >> From: Minchan Kim <minchan@kernel.org>
> >> 
> >> This patch is a preparatory patch for solving race problems caused by
> >> TLB batch.  For that, we will increase/decrease TLB flush pending count
> >> of mm_struct whenever tlb_[gather|finish]_mmu is called.
> >> 
> >> Before making it simple, this patch separates architecture specific
> >> part and rename it to arch_tlb_[gather|finish]_mmu and generic part
> >> just calls it.
> > 
> > I absolutely hate this. We should unify this stuff, not diverge it
> > further.
> 
> Agreed, but I don’t see how this patch makes the situation any worse.

Agree with Nadav. I don't think this patch makes things diverge further.
Peter, If you are strong against of it, please tell us what part you
are hating.

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

Re: [PATCH v6 4/7] mm: refactoring TLB gathering API Minchan Kim <minchan@kernel.org> - 2017-08-14 02:50 +0200

csiph-web