Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1705416

Re: [PATCH 1/4] PM / s2idle: Rename PM_SUSPEND_FREEZE to PM_SUSPEND_S2IDLE

From "Rafael J. Wysocki" <rafael@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH 1/4] PM / s2idle: Rename PM_SUSPEND_FREEZE to PM_SUSPEND_S2IDLE
Date 2017-08-07 14:10 +0200
Message-ID <ubP17-80C-3@gated-at.bofh.it> (permalink)
References <ub705-5pg-1@gated-at.bofh.it> <ub705-5pg-5@gated-at.bofh.it> <ubM3g-5YJ-15@gated-at.bofh.it> <ubORt-7Id-39@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Mon, Aug 7, 2017 at 1:57 PM, Rafael J. Wysocki <rafael@kernel.org> wrote:
> On Mon, Aug 7, 2017 at 10:49 AM, Peter Zijlstra <peterz@infradead.org> wrote:
>> On Sat, Aug 05, 2017 at 02:56:43PM +0200, Rafael J. Wysocki wrote:
>>> From: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
>>>
>>> To make it clear that the symbol in question refers to
>>> suspend-to-idle, rename it from PM_SUSPEND_FREEZE to
>>> PM_SUSPEND_S2IDLE.
>>>
>>> Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
>>> ---
>>>  drivers/acpi/sleep.c             |    2 -
>>>  drivers/regulator/of_regulator.c |    2 -
>>>  include/linux/suspend.h          |    4 +--
>>>  kernel/power/suspend.c           |   44 +++++++++++++++++++--------------------
>>>  kernel/power/suspend_test.c      |    4 +--
>>>  5 files changed, 28 insertions(+), 28 deletions(-)
>>>
>>> Index: linux-pm/include/linux/suspend.h
>>> ===================================================================
>>> --- linux-pm.orig/include/linux/suspend.h
>>> +++ linux-pm/include/linux/suspend.h
>>> @@ -33,10 +33,10 @@ static inline void pm_restore_console(vo
>>>  typedef int __bitwise suspend_state_t;
>>>
>>>  #define PM_SUSPEND_ON                ((__force suspend_state_t) 0)
>>> -#define PM_SUSPEND_FREEZE    ((__force suspend_state_t) 1)
>>> +#define PM_SUSPEND_S2IDLE    ((__force suspend_state_t) 1)
>>>  #define PM_SUSPEND_STANDBY   ((__force suspend_state_t) 2)
>>>  #define PM_SUSPEND_MEM               ((__force suspend_state_t) 3)
>>
>> I feel something like PM_SUSPEND_IDLE is more consistent with the
>> existing PM_SUSPEND_MEM. Also the proposed PM_SUSPEND_S2IDLE has
>> 'SUSPEND' in it twice, so at the very least it should be
>> PM_SUSPEND_2IDLE :-)
>>
>>
>>> -#define PM_SUSPEND_MIN               PM_SUSPEND_FREEZE
>>> +#define PM_SUSPEND_MIN               PM_SUSPEND_S2IDLE
>>>  #define PM_SUSPEND_MAX               ((__force suspend_state_t) 4)
>
> OK, I can call it PM_SUSPEND_IDLE no problem.

Actually, I'm thinking that PM_SUSPEND_TO_IDLE may be even better ...

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 0/4] PM: Replace "freeze" with "s2idle" in item names related to suspend-to-idle "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-05 15:10 +0200
  [PATCH 1/4] PM / s2idle: Rename PM_SUSPEND_FREEZE to PM_SUSPEND_S2IDLE "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-05 15:10 +0200
    Re: [PATCH 1/4] PM / s2idle: Rename PM_SUSPEND_FREEZE to  PM_SUSPEND_S2IDLE Peter Zijlstra <peterz@infradead.org> - 2017-08-07 11:00 +0200
      Re: [PATCH 1/4] PM / s2idle: Rename PM_SUSPEND_FREEZE to PM_SUSPEND_S2IDLE "Rafael J. Wysocki" <rafael@kernel.org> - 2017-08-07 14:00 +0200
        Re: [PATCH 1/4] PM / s2idle: Rename PM_SUSPEND_FREEZE to PM_SUSPEND_S2IDLE "Rafael J. Wysocki" <rafael@kernel.org> - 2017-08-07 14:10 +0200
  [PATCH 4/4] PM / s2idle: Rename platform operations structure "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-05 15:10 +0200
  [PATCH 2/4] PM / s2idle: Rename freeze_state enum and related items "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-05 15:20 +0200
  [PATCH 3/4] PM / s2idle: Rename ->enter_freeze to ->enter_s2idle "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-05 15:20 +0200
  [PATCH v2 1/4] PM / s2idle: Rename PM_SUSPEND_FREEZE to PM_SUSPEND_TO_IDLE "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-10 00:30 +0200
  [PATCH v2 0/4] PM: Replace "freeze" with "s2idle" in item names related to suspend-to-idle "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-10 00:30 +0200
    [PATCH v2 3/4] PM / s2idle: Rename ->enter_freeze to ->enter_s2idle "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-10 00:30 +0200
    [PATCH v2 4/4] PM / s2idle: Rename platform operations structure "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-10 00:30 +0200
    [PATCH v2 2/4] PM / s2idle: Rename freeze_state enum and related items "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-10 00:30 +0200

csiph-web