Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1704642
| From | "Rafael J. Wysocki" <rjw@rjwysocki.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 0/4] PM: Replace "freeze" with "s2idle" in item names related to suspend-to-idle |
| Date | 2017-08-05 15:10 +0200 |
| Message-ID | <ub705-5pg-1@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
Hi Everyone, The term "suspend-to-idle" (and its short form "s2idle") was invented after introducing support for the system state it refers to. At that time, the feature was called "freeze", kind of for the lack of a better idea how to call it. It would not be a problem if it wasn't confusing, but alas it is. The word "freeze" is quite heavily loaded in the PM terminology. It is related to the freezing of tasks, the freezing of filesystems (which isn't only used for PM for that matter), and one of the phases of handling devices during hibernation (and during resume from it) is called "freeze", which is reflected in the names of PM callbacks used by it. To avoid that confusion, the following patches change the names of various items related to suspend-to-idle by replacing the word "freeze" in them with "s2idle". The series is on top of current linux-next. Thanks, Rafael
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH 0/4] PM: Replace "freeze" with "s2idle" in item names related to suspend-to-idle "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-05 15:10 +0200
[PATCH 1/4] PM / s2idle: Rename PM_SUSPEND_FREEZE to PM_SUSPEND_S2IDLE "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-05 15:10 +0200
Re: [PATCH 1/4] PM / s2idle: Rename PM_SUSPEND_FREEZE to PM_SUSPEND_S2IDLE Peter Zijlstra <peterz@infradead.org> - 2017-08-07 11:00 +0200
Re: [PATCH 1/4] PM / s2idle: Rename PM_SUSPEND_FREEZE to PM_SUSPEND_S2IDLE "Rafael J. Wysocki" <rafael@kernel.org> - 2017-08-07 14:00 +0200
Re: [PATCH 1/4] PM / s2idle: Rename PM_SUSPEND_FREEZE to PM_SUSPEND_S2IDLE "Rafael J. Wysocki" <rafael@kernel.org> - 2017-08-07 14:10 +0200
[PATCH 4/4] PM / s2idle: Rename platform operations structure "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-05 15:10 +0200
[PATCH 2/4] PM / s2idle: Rename freeze_state enum and related items "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-05 15:20 +0200
[PATCH 3/4] PM / s2idle: Rename ->enter_freeze to ->enter_s2idle "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-05 15:20 +0200
[PATCH v2 1/4] PM / s2idle: Rename PM_SUSPEND_FREEZE to PM_SUSPEND_TO_IDLE "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-10 00:30 +0200
[PATCH v2 0/4] PM: Replace "freeze" with "s2idle" in item names related to suspend-to-idle "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-10 00:30 +0200
[PATCH v2 3/4] PM / s2idle: Rename ->enter_freeze to ->enter_s2idle "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-10 00:30 +0200
[PATCH v2 4/4] PM / s2idle: Rename platform operations structure "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-10 00:30 +0200
[PATCH v2 2/4] PM / s2idle: Rename freeze_state enum and related items "Rafael J. Wysocki" <rjw@rjwysocki.net> - 2017-08-10 00:30 +0200
csiph-web