Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1700369

Re: [PATCH 3/3] EDAC, ghes: Make it a proper module

From "Kani, Toshimitsu" <toshi.kani@hpe.com>
Newsgroups linux.kernel
Subject Re: [PATCH 3/3] EDAC, ghes: Make it a proper module
Date 2017-07-31 22:20 +0200
Message-ID <u9pku-2jJ-13@gated-at.bofh.it> (permalink)
References <u7qb0-6t0-7@gated-at.bofh.it> <u7qkG-6w4-9@gated-at.bofh.it> <u8iEp-7vB-9@gated-at.bofh.it> <u8tJv-6SE-7@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Sat, 2017-07-29 at 08:47 +0200, Borislav Petkov wrote:
> On Fri, Jul 28, 2017 at 06:50:56PM +0000, Kani, Toshimitsu wrote:
> > This simply sets NULL to pvt, and does not initialize ghes_pvt.
> 
> Yeah, I guess we need this ontop:

Yes, this fix looks good.

> >  As Mauro pointed out, some type of GHES check needs to be in place
> > before making this change.
> 
> Your whitelist I guess.

We still need the two mechanisms provided by the existing code below. 
The whitelist simply compliments 1.

1. GHES-presence check.  (We can add APEI OSC bit check as well.)
2. Module priority.  ghes_edac has higher priority for registration.

I'd prefer to add the whitelist check to ghes_edac first.  This makes
the existing code to work.  We can then work on refactoring changes
like this on top of it without breaking the functionality.

Thanks,
-Toshi

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 0/3] EDAC: Convert ghes_edac to a normal module Borislav Petkov <bp@alien8.de> - 2017-07-26 10:50 +0200
  [PATCH 2/3] ACPI/GHES: Add an EDAC notifier chain Borislav Petkov <bp@alien8.de> - 2017-07-26 10:50 +0200
  [PATCH 3/3] EDAC, ghes: Make it a proper module Borislav Petkov <bp@alien8.de> - 2017-07-26 11:00 +0200
    Re: [PATCH 3/3] EDAC, ghes: Make it a proper module Mauro Carvalho Chehab <mchehab@infradead.org> - 2017-07-26 12:30 +0200
      Re: [PATCH 3/3] EDAC, ghes: Make it a proper module Borislav Petkov <bp@alien8.de> - 2017-07-26 12:40 +0200
        Re: [PATCH 3/3] EDAC, ghes: Make it a proper module Mauro Carvalho Chehab <mchehab@infradead.org> - 2017-07-26 13:00 +0200
          RE: [PATCH 3/3] EDAC, ghes: Make it a proper module "Luck, Tony" <tony.luck@intel.com> - 2017-07-26 19:30 +0200
            Re: [PATCH 3/3] EDAC, ghes: Make it a proper module Mauro Carvalho Chehab <mchehab@infradead.org> - 2017-07-26 20:20 +0200
              Re: [PATCH 3/3] EDAC, ghes: Make it a proper module "Kani, Toshimitsu" <toshi.kani@hpe.com> - 2017-07-26 21:30 +0200
                Re: [PATCH 3/3] EDAC, ghes: Make it a proper module Borislav Petkov <bp@alien8.de> - 2017-07-27 07:30 +0200
      Re: [PATCH 3/3] EDAC, ghes: Make it a proper module "Kani, Toshimitsu" <toshi.kani@hpe.com> - 2017-07-26 21:50 +0200
    Re: [PATCH 3/3] EDAC, ghes: Make it a proper module "Kani, Toshimitsu" <toshi.kani@hpe.com> - 2017-07-28 21:00 +0200
      Re: [PATCH 3/3] EDAC, ghes: Make it a proper module Borislav Petkov <bp@alien8.de> - 2017-07-29 08:50 +0200
        Re: [PATCH 3/3] EDAC, ghes: Make it a proper module "Kani, Toshimitsu" <toshi.kani@hpe.com> - 2017-07-31 22:20 +0200
          Re: [PATCH 3/3] EDAC, ghes: Make it a proper module Borislav Petkov <bp@alien8.de> - 2017-08-01 11:50 +0200
            Re: [PATCH 3/3] EDAC, ghes: Make it a proper module "Kani, Toshimitsu" <toshi.kani@hpe.com> - 2017-08-02 02:30 +0200
              Re: [PATCH 3/3] EDAC, ghes: Make it a proper module Borislav Petkov <bp@alien8.de> - 2017-08-02 05:20 +0200
                Re: [PATCH 3/3] EDAC, ghes: Make it a proper module "Kani, Toshimitsu" <toshi.kani@hpe.com> - 2017-08-03 00:50 +0200
  Re: [PATCH 0/3] EDAC: Convert ghes_edac to a normal module Borislav Petkov <bp@alien8.de> - 2017-07-27 08:00 +0200

csiph-web