Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1699815

Re: [PATCH 6/8] dmi: Move memdev_dmi_entry definition to dmi.h (v2)

From Jean Delvare <jdelvare@suse.de>
Newsgroups linux.kernel
Subject Re: [PATCH 6/8] dmi: Move memdev_dmi_entry definition to dmi.h (v2)
Date 2017-07-31 10:40 +0200
Message-ID <u9ep4-3Xg-11@gated-at.bofh.it> (permalink)
References <rap5F-Qj-47@gated-at.bofh.it> <rauI1-4Kx-3@gated-at.bofh.it> <rdGWl-8uZ-1@gated-at.bofh.it>
Organization SUSE Linux

Show all headers | View raw


Hi Matt, Mauro,

On Thu, 17 Mar 2016 15:18:20 +0100, Jean Delvare wrote:
> On Tue,  8 Mar 2016 10:32:37 -0800, Matt Roper wrote:
> > A couple of the EDAC drivers have a nice memdev_dmi_entry structure for
> > decoding DMI memory device entries.  Move the structure definition to
> > dmi.h so that it can be shared between those drivers and also other
> > parts of the kernel; the i915 graphics driver is going to need to use
> > this structure soon as well.  As part of this move we rename the
> > structure s/memdev_dmi_entry/dmi_entry_memdev/ to ensure it has a proper
> > 'dmi' prefix.
> > 
> > v2:
> >  - Rename structure to dmi_entry_memdev.  (Jean)
> >  - Use __packed instead of __attribute__((__packed__)) for consistency
> >    with the rest of the dmi.h header.  (Jean)  
> 
> Looks better. (...)

What happened to this patch? I never received v3. Is it sill needed?

-- 
Jean Delvare
SUSE L3 Support

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

Re: [PATCH 6/8] dmi: Move memdev_dmi_entry definition to dmi.h (v2) Jean Delvare <jdelvare@suse.de> - 2017-07-31 10:40 +0200
  Re: [PATCH 6/8] dmi: Move memdev_dmi_entry definition to dmi.h (v2) Matt Roper <matthew.d.roper@intel.com> - 2017-08-09 18:20 +0200
    Re: [PATCH 6/8] dmi: Move memdev_dmi_entry definition to dmi.h (v2) Jean Delvare <jdelvare@suse.de> - 2017-08-10 11:40 +0200

csiph-web