Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1690112
| From | tip-bot for Baoquan He <tipbot@zytor.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [tip:x86/boot] x86/boot/KASLR: Rename process_e820_entry() into process_mem_region() |
| Date | 2017-07-18 13:00 +0200 |
| Message-ID | <u4yor-1lh-57@gated-at.bofh.it> (permalink) |
| References | <u1jFf-7Je-9@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Commit-ID: 27aac20574110abfd594175a668dc58b23b2b14a
Gitweb: http://git.kernel.org/tip/27aac20574110abfd594175a668dc58b23b2b14a
Author: Baoquan He <bhe@redhat.com>
AuthorDate: Sun, 9 Jul 2017 20:37:41 +0800
Committer: Ingo Molnar <mingo@kernel.org>
CommitDate: Tue, 18 Jul 2017 11:11:12 +0200
x86/boot/KASLR: Rename process_e820_entry() into process_mem_region()
Now process_e820_entry() is not limited to e820 entry processing, rename
it to process_mem_region(). And adjust the code comment accordingly.
Signed-off-by: Baoquan He <bhe@redhat.com>
Acked-by: Kees Cook <keescook@chromium.org>
Cc: Linus Torvalds <torvalds@linux-foundation.org>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: fanc.fnst@cn.fujitsu.com
Cc: izumi.taku@jp.fujitsu.com
Cc: matt@codeblueprint.co.uk
Cc: thgarnie@google.com
Link: http://lkml.kernel.org/r/1499603862-11516-4-git-send-email-bhe@redhat.com
Signed-off-by: Ingo Molnar <mingo@kernel.org>
---
arch/x86/boot/compressed/kaslr.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/arch/x86/boot/compressed/kaslr.c b/arch/x86/boot/compressed/kaslr.c
index 36ff9f7..99c7194f 100644
--- a/arch/x86/boot/compressed/kaslr.c
+++ b/arch/x86/boot/compressed/kaslr.c
@@ -479,7 +479,7 @@ static unsigned long slots_fetch_random(void)
return 0;
}
-static void process_e820_entry(struct mem_vector *entry,
+static void process_mem_region(struct mem_vector *entry,
unsigned long minimum,
unsigned long image_size)
{
@@ -517,7 +517,7 @@ static void process_e820_entry(struct mem_vector *entry,
/* Potentially raise address to meet alignment needs. */
region.start = ALIGN(region.start, CONFIG_PHYSICAL_ALIGN);
- /* Did we raise the address above this e820 region? */
+ /* Did we raise the address above the passed in memory entry? */
if (region.start > cur_entry.start + cur_entry.size)
return;
@@ -573,7 +573,7 @@ static void process_e820_entries(unsigned long minimum,
continue;
region.start = entry->addr;
region.size = entry->size;
- process_e820_entry(®ion, minimum, image_size);
+ process_mem_region(®ion, minimum, image_size);
if (slot_area_index == MAX_SLOT_AREA) {
debug_putstr("Aborted e820 scan (slot_areas full)!\n");
break;
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v4 0/4] x86/boot/KASLR: Restrict kernel to be randomized in mirror regions Baoquan He <bhe@redhat.com> - 2017-07-09 14:40 +0200
[PATCH v4 2/4] x86/boot/KASLR: Switch to pass struct mem_vector to process_e820_entry() Baoquan He <bhe@redhat.com> - 2017-07-09 14:40 +0200
Re: [PATCH v4 2/4] x86/boot/KASLR: Switch to pass struct mem_vector to process_e820_entry() Kees Cook <keescook@chromium.org> - 2017-07-09 16:10 +0200
[tip:x86/boot] x86/boot/KASLR: Switch to pass struct mem_vector to process_e820_entry() tip-bot for Baoquan He <tipbot@zytor.com> - 2017-07-18 13:00 +0200
[PATCH v4 3/4] x86/boot/KASLR: Rename process_e820_entry() into process_mem_region() Baoquan He <bhe@redhat.com> - 2017-07-09 14:40 +0200
Re: [PATCH v4 3/4] x86/boot/KASLR: Rename process_e820_entry() into process_mem_region() Kees Cook <keescook@chromium.org> - 2017-07-09 16:10 +0200
[tip:x86/boot] x86/boot/KASLR: Rename process_e820_entry() into process_mem_region() tip-bot for Baoquan He <tipbot@zytor.com> - 2017-07-18 13:00 +0200
[PATCH v4 4/4] x86/boot/KASLR: Restrict kernel to be randomized in mirror regions Baoquan He <bhe@redhat.com> - 2017-07-09 14:40 +0200
Re: [PATCH v4 4/4] x86/boot/KASLR: Restrict kernel to be randomized in mirror regions Kees Cook <keescook@chromium.org> - 2017-07-09 16:20 +0200
Re: [PATCH v4 4/4] x86/boot/KASLR: Restrict kernel to be randomized in mirror regions Baoquan He <bhe@redhat.com> - 2017-07-09 16:30 +0200
Re: [PATCH v4 4/4] x86/boot/KASLR: Restrict kernel to be randomized in mirror regions Baoquan He <bhe@redhat.com> - 2017-07-10 03:50 +0200
Re: [PATCH v4 4/4] x86/boot/KASLR: Restrict kernel to be randomized in mirror regions Chao Fan <fanc.fnst@cn.fujitsu.com> - 2017-07-10 04:50 +0200
Re: [PATCH v4 4/4] x86/boot/KASLR: Restrict kernel to be randomized in mirror regions Baoquan He <bhe@redhat.com> - 2017-07-10 10:00 +0200
[PATCH v4 1/4] x86/boot/KASLR: Wrap e820 entries walking code into new function process_e820_entries() Baoquan He <bhe@redhat.com> - 2017-07-09 14:40 +0200
Re: [PATCH v4 1/4] x86/boot/KASLR: Wrap e820 entries walking code into new function process_e820_entries() Kees Cook <keescook@chromium.org> - 2017-07-09 16:10 +0200
[tip:x86/boot] x86/boot/KASLR: Wrap e820 entries walking code into new function process_e820_entries() tip-bot for Baoquan He <tipbot@zytor.com> - 2017-07-18 12:50 +0200
csiph-web