Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1683914

Re: [PATCH v4 4/4] x86/boot/KASLR: Restrict kernel to be randomized in mirror regions

From Chao Fan <fanc.fnst@cn.fujitsu.com>
Newsgroups linux.kernel
Subject Re: [PATCH v4 4/4] x86/boot/KASLR: Restrict kernel to be randomized in mirror regions
Date 2017-07-10 04:50 +0200
Message-ID <u1wVQ-7Bs-1@gated-at.bofh.it> (permalink)
References <u1jFf-7Je-3@gated-at.bofh.it> <u1jFg-7Je-11@gated-at.bofh.it> <u1le1-iT-15@gated-at.bofh.it> <u1vZL-6V4-7@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Mon, Jul 10, 2017 at 09:47:29AM +0800, Baoquan He wrote:
>On 07/09/17 at 07:11am, Kees Cook wrote:
>> On Sun, Jul 9, 2017 at 5:37 AM, Baoquan He <bhe@redhat.com> wrote:
>> > Signed-off-by: Baoquan He <bhe@redhat.com>
>> > +/* Marks if efi mirror regions have been found and handled. */
>> > +static bool efi_mirror_found;
>> 
>> I think this is only ever checked once? How about having
>> process_efi_entries return bool to indicate if mirror was found? Also,
>> that function should be behind #ifdef. Let's do something like this:
>> 
>> 
>> > +
>> > +static void process_efi_entries(unsigned long minimum,
>> > +                               unsigned long image_size)
>> 
>> #ifdef CONFIG_EFI
>> /* Returns true if mirror region found (and further scanning should stop) */
>
>Well, here it might be not like that. The mirror regions could be multiple,
>we need find and process each of them to add slots. 

Yes, in my test, I found the memory situation is like this:

0-1325M:	mirror	(this scope contains tens of entries)
1532M-2303M:	non-mirror
4G-128G:	non-mirror
129G-154G:	mirror
154G-231G:	non-mirror

Thanks,
Chao Fan

>
>> static bool process_efi_entries(...)
>> {
>> ...
>> }
>> #else
>> static inline bool process_efi_entries(...)
>> {
>>     return false;
>> }
>> #endif
>> 
>> Then:
>> 
>> > +#ifdef CONFIG_EFI
>> > +       process_efi_entries(minimum, image_size);
>> > +       if (efi_mirror_found)
>> > +               return slots_fetch_random();
>> > +#endif
>> 
>> Can become:
>> 
>> if (process_efi_entries(minimum, image_size))
>>     return slots_fetch_random()
>> 
>> and no #ifndef needed here.
>> 
>> > +
>> >         process_e820_entries(minimum, image_size);
>> >         return slots_fetch_random();
>> >  }
>> > @@ -652,7 +708,7 @@ void choose_random_location(unsigned long input,
>> >          */
>> >         min_addr = min(*output, 512UL << 20);
>> >
>> > -       /* Walk e820 and find a random address. */
>> > +       /* Walk available memory entries to find a random address. */
>> >         random_addr = find_random_phys_addr(min_addr, output_size);
>> >         if (!random_addr) {
>> >                 warn("Physical KASLR disabled: no suitable memory region!");
>> > --
>> > 2.5.5
>> >
>> 
>> Otherwise, if the EFI logic is good, this looks sensible.
>> 
>> Thanks for splitting up the patches!
>> 
>> -Kees
>> 
>> -- 
>> Kees Cook
>> Pixel Security
>
>

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v4 0/4] x86/boot/KASLR: Restrict kernel to be randomized in mirror regions Baoquan He <bhe@redhat.com> - 2017-07-09 14:40 +0200
  [PATCH v4 2/4] x86/boot/KASLR: Switch to pass struct mem_vector to process_e820_entry() Baoquan He <bhe@redhat.com> - 2017-07-09 14:40 +0200
    Re: [PATCH v4 2/4] x86/boot/KASLR: Switch to pass struct mem_vector  to process_e820_entry() Kees Cook <keescook@chromium.org> - 2017-07-09 16:10 +0200
  [PATCH v4 3/4] x86/boot/KASLR: Rename process_e820_entry() into process_mem_region() Baoquan He <bhe@redhat.com> - 2017-07-09 14:40 +0200
    Re: [PATCH v4 3/4] x86/boot/KASLR: Rename process_e820_entry() into process_mem_region() Kees Cook <keescook@chromium.org> - 2017-07-09 16:10 +0200
  [PATCH v4 4/4] x86/boot/KASLR: Restrict kernel to be randomized in mirror regions Baoquan He <bhe@redhat.com> - 2017-07-09 14:40 +0200
    Re: [PATCH v4 4/4] x86/boot/KASLR: Restrict kernel to be randomized  in mirror regions Kees Cook <keescook@chromium.org> - 2017-07-09 16:20 +0200
      Re: [PATCH v4 4/4] x86/boot/KASLR: Restrict kernel to be randomized  in mirror regions Baoquan He <bhe@redhat.com> - 2017-07-09 16:30 +0200
      Re: [PATCH v4 4/4] x86/boot/KASLR: Restrict kernel to be randomized  in mirror regions Baoquan He <bhe@redhat.com> - 2017-07-10 03:50 +0200
        Re: [PATCH v4 4/4] x86/boot/KASLR: Restrict kernel to be randomized  in mirror regions Chao Fan <fanc.fnst@cn.fujitsu.com> - 2017-07-10 04:50 +0200
      Re: [PATCH v4 4/4] x86/boot/KASLR: Restrict kernel to be randomized  in mirror regions Baoquan He <bhe@redhat.com> - 2017-07-10 10:00 +0200
  [PATCH v4 1/4] x86/boot/KASLR: Wrap e820 entries walking code into new function process_e820_entries() Baoquan He <bhe@redhat.com> - 2017-07-09 14:40 +0200
    Re: [PATCH v4 1/4] x86/boot/KASLR: Wrap e820 entries walking code  into new function process_e820_entries() Kees Cook <keescook@chromium.org> - 2017-07-09 16:10 +0200

csiph-web