Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1690618
| From | Greg Kroah-Hartman <gregkh@linuxfoundation.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 2/2] sysfs: add devm_sysfs_create_group() and friends |
| Date | 2017-07-18 22:10 +0200 |
| Message-ID | <u4GYF-6V8-9@gated-at.bofh.it> (permalink) |
| References | <u4GvD-6vZ-13@gated-at.bofh.it> <u4GvE-6vZ-27@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, Jul 18, 2017 at 12:30:58PM -0700, Dmitry Torokhov wrote: > --- a/include/linux/sysfs.h > +++ b/include/linux/sysfs.h > @@ -282,6 +282,16 @@ int __compat_only_sysfs_link_entry_to_kobj(struct kobject *kobj, > struct kobject *target_kobj, > const char *target_name); > > +struct device; Put this in device.h instead? > +int __must_check devm_sysfs_create_group(struct device *dev, > + const struct attribute_group *grp); > +int __must_check devm_sysfs_create_groups(struct device *dev, > + const struct attribute_group **groups); > +void devm_sysfs_remove_group(struct device *dev, > + const struct attribute_group *grp); > +void devm_sysfs_remove_groups(struct device *dev, > + const struct attribute_group **groups); I have finally moved the driver core to only accept/need "groups" not a single "group", so we should only need devm_sysfs_create_groups and devm_sysfs_remove_groups, right? And do we need/want the non-devm versions: device_create_groups() device_remove_groups() ? And you can probably drop the 'sysfs' from the function name if you want. </bikeshedding> :) thanks, greg k-h
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/2] New bind/unbingd uevents Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2017-07-18 21:40 +0200
[PATCH 2/2] sysfs: add devm_sysfs_create_group() and friends Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2017-07-18 21:40 +0200
Re: [PATCH 2/2] sysfs: add devm_sysfs_create_group() and friends Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2017-07-18 22:10 +0200
Re: [PATCH 2/2] sysfs: add devm_sysfs_create_group() and friends Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2017-07-18 22:30 +0200
Re: [PATCH 2/2] sysfs: add devm_sysfs_create_group() and friends Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2017-07-19 09:40 +0200
Re: [PATCH 0/2] New bind/unbingd uevents Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2017-07-18 22:10 +0200
csiph-web