Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1690428

Re: [PATCH v2 9/9] soc: mediatek: pwrap: fixup warnings from coding style

From Yingjoe Chen <yingjoe.chen@mediatek.com>
Newsgroups linux.kernel
Subject Re: [PATCH v2 9/9] soc: mediatek: pwrap: fixup warnings from coding style
Date 2017-07-18 18:30 +0200
Message-ID <u4DxM-4G9-29@gated-at.bofh.it> (permalink)
References <u4xiG-HH-37@gated-at.bofh.it> <u4xso-Lp-59@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


[Resend due to bad mail format, sorry about the noise if you got two]


On Tue, 2017-07-18 at 17:49 +0800, sean.wang@mediatek.com wrote:
> From: Sean Wang <sean.wang@mediatek.com>
> 
> fixup those warnings such as lines over 80 words and parenthesis
> alignment which would be complained by checkpatch.pl.
> 
> Signed-off-by: Sean Wang <sean.wang@mediatek.com>
> ---
>  drivers/soc/mediatek/mtk-pmic-wrap.c | 20 +++++++++++++-------
>  1 file changed, 13 insertions(+), 7 deletions(-)
> 
> diff --git a/drivers/soc/mediatek/mtk-pmic-wrap.c b/drivers/soc/mediatek/mtk-pmic-wrap.c
> index 142f40a..5f1036f 100644
> --- a/drivers/soc/mediatek/mtk-pmic-wrap.c
> +++ b/drivers/soc/mediatek/mtk-pmic-wrap.c
> @@ -1057,7 +1057,8 @@ static int pwrap_init_cipher(struct pmic_wrapper *wrp)
>  	/* wait for cipher data ready@PMIC */
>  	ret = pwrap_wait_for_state(wrp, pwrap_is_pmic_cipher_ready);
>  	if (ret) {
> -		dev_err(wrp->dev, "timeout waiting for cipher data ready@PMIC\n");
> +		dev_err(wrp->dev,
> +			"timeout waiting for cipher data ready@PMIC\n");

Sean,

I think the old code is easier to read. When the line is only slightly
over the 80 chars limit, some maintainers will even ask to keep it in
one line to make it easier to read.

So if it is OK with Matthias, I think we should just keep it as is.

Joe.C

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2 0/9] Add PMIC support to MediaTek MT7622 SoC <sean.wang@mediatek.com> - 2017-07-18 11:50 +0200
  [PATCH v2 8/9] soc: mediatek: pwrap: add support for MT7622 SoC <sean.wang@mediatek.com> - 2017-07-18 12:00 +0200
  [PATCH v2 3/9] regulator: mt6380: Add support for MT6380 <sean.wang@mediatek.com> - 2017-07-18 12:00 +0200
    Re: [PATCH v2 3/9] regulator: mt6380: Add support for MT6380 Mark Brown <broonie@kernel.org> - 2017-07-18 15:40 +0200
  [PATCH v2 7/9] soc: mediatek: pwrap: add MediaTek MT6380 as one slave of pwrap <sean.wang@mediatek.com> - 2017-07-18 12:00 +0200
  [PATCH v2 9/9] soc: mediatek: pwrap: fixup warnings from coding style <sean.wang@mediatek.com> - 2017-07-18 12:00 +0200
    Re: [PATCH v2 9/9] soc: mediatek: pwrap: fixup warnings from coding  style Yingjoe Chen <yingjoe.chen@mediatek.com> - 2017-07-18 18:30 +0200
      Re: [PATCH v2 9/9] soc: mediatek: pwrap: fixup warnings from coding  style Joe Perches <joe@perches.com> - 2017-07-18 18:40 +0200
  [PATCH v2 1/9] dt-bindings: arm: mediatek: add MT7622 string to the PMIC wrapper doc <sean.wang@mediatek.com> - 2017-07-18 12:00 +0200
    Re: [PATCH v2 1/9] dt-bindings: arm: mediatek: add MT7622 string to  the PMIC wrapper doc Yingjoe Chen <yingjoe.chen@mediatek.com> - 2017-07-18 18:10 +0200
      Re: [PATCH v2 1/9] dt-bindings: arm: mediatek: add MT7622 string to  the PMIC wrapper doc Sean Wang <sean.wang@mediatek.com> - 2017-07-19 05:00 +0200
  [PATCH v2 4/9] soc: mediatek: pwrap: add pwrap_read32 for reading in 32-bit mode <sean.wang@mediatek.com> - 2017-07-18 12:00 +0200
  [PATCH v2 6/9] soc: mediatek: pwrap: update pwrap_init without slave programming <sean.wang@mediatek.com> - 2017-07-18 12:00 +0200
  [PATCH v2 5/9] soc: mediatek: pwrap: add pwrap_write32 for writing in 32-bit mode <sean.wang@mediatek.com> - 2017-07-18 12:00 +0200

csiph-web