Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1626896

Re: [PATCH v2] dma-buf: Rename dma-ops to prevent conflict with kunmap_atomic macro

From Laura Abbott <labbott@redhat.com>
Newsgroups linux.kernel
Subject Re: [PATCH v2] dma-buf: Rename dma-ops to prevent conflict with kunmap_atomic macro
Date 2017-04-20 02:30 +0200
Message-ID <ty88V-1LI-1@gated-at.bofh.it> (permalink)
References <ty3Ci-7ov-19@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 04/19/2017 12:36 PM, Logan Gunthorpe wrote:
> Seeing the kunmap_atomic dma_buf_ops share the same name with a macro
> in highmem.h, the former can be aliased if any dma-buf user includes
> that header.
> 
> I'm personally trying to include highmem.h inside scatterlist.h and this
> breaks the dma-buf code proper.
> 
> Christoph Hellwig suggested [1] renaming it and pushing this patch ASAP.
> 
> To maintain consistency I've renamed all four of kmap* and kunmap* to be
> map* and unmap*. (Even though only kmap_atomic presently conflicts.)
> 
> [1] https://www.spinics.net/lists/target-devel/msg15070.html
> 
> Signed-off-by: Logan Gunthorpe <logang@deltatee.com>
> Reviewed-by: Sinclair Yeh <syeh@vmware.com>
> ---
> 
> Changes since v1:
> 
> - Added the missing tegra driver (noticed by kbuild robot)
> - Rebased off of drm-intel-next to get the i915 selftest that is new
> - Fixed nits Sinclair pointed out.
> 
>   drivers/dma-buf/dma-buf.c                      | 16 ++++++++--------
>   drivers/gpu/drm/armada/armada_gem.c            |  8 ++++----
>   drivers/gpu/drm/drm_prime.c                    |  8 ++++----
>   drivers/gpu/drm/i915/i915_gem_dmabuf.c         |  8 ++++----
>   drivers/gpu/drm/i915/selftests/mock_dmabuf.c   |  8 ++++----
>   drivers/gpu/drm/omapdrm/omap_gem_dmabuf.c      |  8 ++++----
>   drivers/gpu/drm/tegra/gem.c                    |  8 ++++----
>   drivers/gpu/drm/udl/udl_dmabuf.c               |  8 ++++----
>   drivers/gpu/drm/vmwgfx/vmwgfx_prime.c          |  8 ++++----
>   drivers/media/v4l2-core/videobuf2-dma-contig.c |  4 ++--
>   drivers/media/v4l2-core/videobuf2-dma-sg.c     |  4 ++--
>   drivers/media/v4l2-core/videobuf2-vmalloc.c    |  4 ++--
>   drivers/staging/android/ion/ion.c              |  8 ++++----
>   include/linux/dma-buf.h                        | 22 +++++++++++-----------
>   14 files changed, 61 insertions(+), 61 deletions(-)
> 

For Ion,

Acked-by: Laura Abbott <labbott@redhat.com>

I did some major Ion refactoring but I don't think this
will conflict.

Thanks,
Laura

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2] dma-buf: Rename dma-ops to prevent conflict with kunmap_atomic macro Logan Gunthorpe <logang@deltatee.com> - 2017-04-19 21:40 +0200
  Re: [PATCH v2] dma-buf: Rename dma-ops to prevent conflict with  kunmap_atomic macro Laura Abbott <labbott@redhat.com> - 2017-04-20 02:30 +0200
  Re: [Intel-gfx] [PATCH v2] dma-buf: Rename dma-ops to prevent  conflict with kunmap_atomic macro Daniel Vetter <daniel@ffwll.ch> - 2017-04-20 10:00 +0200
    Re: [Intel-gfx] [PATCH v2] dma-buf: Rename dma-ops to prevent conflict  with kunmap_atomic macro Marek Szyprowski <m.szyprowski@samsung.com> - 2017-04-20 10:10 +0200
      Re: [Intel-gfx] [PATCH v2] dma-buf: Rename dma-ops to prevent  conflict with kunmap_atomic macro Sumit Semwal <sumit.semwal@linaro.org> - 2017-04-20 10:20 +0200
    Re: [Intel-gfx] [PATCH v2] dma-buf: Rename dma-ops to prevent  conflict with kunmap_atomic macro Sumit Semwal <sumit.semwal@linaro.org> - 2017-04-20 10:10 +0200

csiph-web