Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1626394

Re: [PATCH v3 3/7] kprobes: validate the symbol name length

From Masami Hiramatsu <mhiramat@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH v3 3/7] kprobes: validate the symbol name length
Date 2017-04-19 17:40 +0200
Message-ID <txZS2-59Y-17@gated-at.bofh.it> (permalink)
References <txXnb-3yQ-3@gated-at.bofh.it> <txXnc-3yQ-25@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Wed, 19 Apr 2017 18:21:02 +0530
"Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com> wrote:

> When a kprobe is being registered, we use the symbol_name field to
> lookup the address where the probe should be placed. Since this is a
> user-provided field, let's ensure that the length of the string is
> within expected limits.

Would we really need this? Of course it may filter out longer
strings... anyway such name should be rejected by kallsyms.

[...]
> diff --git a/kernel/kprobes.c b/kernel/kprobes.c
> index 6a128f3a7ed1..bb86681c8a10 100644
> --- a/kernel/kprobes.c
> +++ b/kernel/kprobes.c
> @@ -1382,6 +1382,28 @@ bool within_kprobe_blacklist(unsigned long addr)
>  	return false;
>  }
>  
> +bool is_valid_kprobe_symbol_name(const char *name)

This just check the length of symbol_name buffer, and can contain
some invalid chars.

> +{
> +	size_t sym_len;
> +	char *s;
> +
> +	s = strchr(name, ':');
> +	if (s) {
> +		sym_len = strnlen(s+1, KSYM_NAME_LEN);

If you use strnlen() here, you just need to ensure sym_len < KSYM_NAME_LEN.

> +		if (sym_len <= 0 || sym_len >= KSYM_NAME_LEN)
> +			return false;
> +		sym_len = (size_t)(s - name);
> +		if (sym_len <= 0 || sym_len >= MODULE_NAME_LEN)
> +			return false;
> +	} else {
> +		sym_len = strnlen(name, MODULE_NAME_LEN);
> +		if (sym_len <= 0 || sym_len >= MODULE_NAME_LEN)

Would you mean KSYM_NAME_LEN here?

> +			return false;
> +	}
> +
> +	return true;
> +}
> +
>  /*
>   * If we have a symbol_name argument, look it up and add the offset field
>   * to it. This way, we can specify a relative address to a symbol.
> @@ -1397,6 +1419,8 @@ static kprobe_opcode_t *kprobe_addr(struct kprobe *p)
>  		goto invalid;
>  
>  	if (p->symbol_name) {
> +		if (!is_valid_kprobe_symbol_name(p->symbol_name))
> +			return ERR_PTR(-EINVAL);
>  		addr = kprobe_lookup_name(p->symbol_name, p->offset);
>  		if (!addr)
>  			return ERR_PTR(-ENOENT);
> diff --git a/kernel/trace/trace_kprobe.c b/kernel/trace/trace_kprobe.c
> index 5f688cc724f0..bf73e5f31128 100644
> --- a/kernel/trace/trace_kprobe.c
> +++ b/kernel/trace/trace_kprobe.c
> @@ -704,6 +704,10 @@ static int create_trace_kprobe(int argc, char **argv)
>  			pr_info("Return probe must be used without offset.\n");
>  			return -EINVAL;
>  		}
> +		if (!is_valid_kprobe_symbol_name(symbol)) {
> +			pr_info("Symbol name is too long.\n");
> +			return -EINVAL;
> +		}
>  	}
>  	argc -= 2; argv += 2;
>  
> -- 
> 2.12.1
> 

Thanks,

-- 
Masami Hiramatsu <mhiramat@kernel.org>

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v3 3/7] kprobes: validate the symbol name length "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com> - 2017-04-19 15:00 +0200
  Re: [PATCH v3 3/7] kprobes: validate the symbol name length Masami Hiramatsu <mhiramat@kernel.org> - 2017-04-19 17:40 +0200
    Re: [PATCH v3 3/7] kprobes: validate the symbol name length "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com> - 2017-04-19 18:40 +0200
      Re: [PATCH v3 3/7] kprobes: validate the symbol name length Masami Hiramatsu <mhiramat@kernel.org> - 2017-04-21 15:50 +0200
        Re: [PATCH v3 3/7] kprobes: validate the symbol name length "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com> - 2017-04-23 17:50 +0200
  Re: [PATCH v3 3/7] kprobes: validate the symbol name length Michael Ellerman <mpe@ellerman.id.au> - 2017-04-20 08:10 +0200
    Re: [PATCH v3 3/7] kprobes: validate the symbol name length "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com> - 2017-04-20 09:30 +0200
  [PATCH v4 4/7] powerpc/kprobes: Use safer string functions in kprobe_lookup_name() "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com> - 2017-04-21 14:40 +0200
    Re: [PATCH v4 4/7] powerpc/kprobes: Use safer string functions in  kprobe_lookup_name() Paul Clarke <pc@us.ibm.com> - 2017-04-21 15:40 +0200
      Re: [PATCH v4 4/7] powerpc/kprobes: Use safer string functions in  kprobe_lookup_name() Paul Clarke <pc@us.ibm.com> - 2017-04-21 15:40 +0200
      Re: [PATCH v4 4/7] powerpc/kprobes: Use safer string functions in  kprobe_lookup_name() Paul Clarke <pc@us.ibm.com> - 2017-04-21 16:00 +0200
        Re: [PATCH v4 4/7] powerpc/kprobes: Use safer string functions in  kprobe_lookup_name() "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com> - 2017-04-23 19:20 +0200
  [PATCH v4 3/7] kprobes: validate the symbol name provided during probe registration "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com> - 2017-04-21 14:40 +0200
    Re: [PATCH v4 3/7] kprobes: validate the symbol name provided during  probe registration Paul Clarke <pc@us.ibm.com> - 2017-04-21 15:20 +0200
      Re: [PATCH v4 3/7] kprobes: validate the symbol name provided during  probe registration "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com> - 2017-04-21 15:30 +0200
    Re: [PATCH v4 3/7] kprobes: validate the symbol name provided  during probe registration Masami Hiramatsu <mhiramat@kernel.org> - 2017-04-21 16:00 +0200
    Re: [PATCH v4 3/7] kprobes: validate the symbol name provided during probe registration Michael Ellerman <mpe@ellerman.id.au> - 2017-04-22 08:00 +0200
      Re: [PATCH v4 3/7] kprobes: validate the symbol name provided during  probe registration "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com> - 2017-04-23 19:50 +0200

csiph-web