Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1622854

[PATCH] mm/madvise: Move up the behavior parameter validation

From Anshuman Khandual <khandual@linux.vnet.ibm.com>
Newsgroups linux.kernel
Subject [PATCH] mm/madvise: Move up the behavior parameter validation
Date 2017-04-13 11:30 +0200
Message-ID <tvJeG-Wr-23@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


The madvise_behavior_valid() function should be called before
acting upon the behavior parameter. Hence move up the function.
This also includes MADV_SOFT_OFFLINE and MADV_HWPOISON options
as valid behavior parameter for the system call madvise().

Signed-off-by: Anshuman Khandual <khandual@linux.vnet.ibm.com>
---
This applies on top of the other madvise clean up patch I sent
earlier this week https://patchwork.kernel.org/patch/9672095/

 mm/madvise.c | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

diff --git a/mm/madvise.c b/mm/madvise.c
index efd4721..3cb427a 100644
--- a/mm/madvise.c
+++ b/mm/madvise.c
@@ -694,6 +694,8 @@ static int madvise_inject_error(int behavior,
 #endif
 	case MADV_DONTDUMP:
 	case MADV_DODUMP:
+	case MADV_SOFT_OFFLINE:
+	case MADV_HWPOISON:
 		return true;
 
 	default:
@@ -767,12 +769,13 @@ static int madvise_inject_error(int behavior,
 	size_t len;
 	struct blk_plug plug;
 
+	if (!madvise_behavior_valid(behavior))
+		return error;
+
 #ifdef CONFIG_MEMORY_FAILURE
 	if (behavior == MADV_HWPOISON || behavior == MADV_SOFT_OFFLINE)
 		return madvise_inject_error(behavior, start, start + len_in);
 #endif
-	if (!madvise_behavior_valid(behavior))
-		return error;
 
 	if (start & ~PAGE_MASK)
 		return error;
-- 
1.8.5.2

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH] mm/madvise: Move up the behavior parameter validation Anshuman Khandual <khandual@linux.vnet.ibm.com> - 2017-04-13 11:30 +0200
  Re: [PATCH] mm/madvise: Move up the behavior parameter validation kbuild test robot <lkp@intel.com> - 2017-04-13 16:00 +0200
  [PATCH V2] mm/madvise: Move up the behavior parameter validation Anshuman Khandual <khandual@linux.vnet.ibm.com> - 2017-04-14 16:00 +0200
    Re: [PATCH V2] mm/madvise: Move up the behavior parameter validation Naoya Horiguchi <n-horiguchi@ah.jp.nec.com> - 2017-04-17 07:30 +0200
      Re: [PATCH V2] mm/madvise: Move up the behavior parameter validation Anshuman Khandual <khandual@linux.vnet.ibm.com> - 2017-04-18 04:50 +0200
  [PATCH V3] mm/madvise: Move up the behavior parameter validation Anshuman Khandual <khandual@linux.vnet.ibm.com> - 2017-04-18 07:30 +0200
    Re: [PATCH V3] mm/madvise: Move up the behavior parameter  validation David Rientjes <rientjes@google.com> - 2017-04-18 23:10 +0200
    Re: [PATCH V3] mm/madvise: Move up the behavior parameter validation Naoya Horiguchi <n-horiguchi@ah.jp.nec.com> - 2017-04-19 02:50 +0200

csiph-web