Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1618711

Re: [PATCH v2 03/11] platform/x86: fujitsu-laptop: merge set_lcd_level_alt() into set_lcd_level()

From Jonathan Woithe <jwoithe@just42.net>
Newsgroups linux.kernel
Subject Re: [PATCH v2 03/11] platform/x86: fujitsu-laptop: merge set_lcd_level_alt() into set_lcd_level()
Date 2017-04-07 14:00 +0200
Message-ID <ttAIx-6Aj-3@gated-at.bofh.it> (permalink)
References <tsMVs-7ys-15@gated-at.bofh.it> <tsN58-7C6-31@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Wed, Apr 05, 2017 at 08:49:02AM +0200, Micha?? K??pie?? wrote:
> diff --git a/drivers/platform/x86/fujitsu-laptop.c b/drivers/platform/x86/fujitsu-laptop.c
> index 59107a599d22..2f563aa00592 100644
> --- a/drivers/platform/x86/fujitsu-laptop.c
> +++ b/drivers/platform/x86/fujitsu-laptop.c
> @@ -360,41 +360,26 @@ static int set_lcd_level(int level)
>  {
>  	acpi_status status = AE_OK;
>  	acpi_handle handle = NULL;
> -
> -	vdbg_printk(FUJLAPTOP_DBG_TRACE, "set lcd level via SBLL [%d]\n",
> -		    level);
> -
> -	if (level < 0 || level >= fujitsu_bl->max_brightness)
> -		return -EINVAL;
> -
> -	status = acpi_get_handle(fujitsu_bl->acpi_handle, "SBLL", &handle);
> -	if (ACPI_FAILURE(status)) {
> -		vdbg_printk(FUJLAPTOP_DBG_ERROR, "SBLL not present\n");
> -		return -ENODEV;
> +	char *method;
> +
> +	switch (use_alt_lcd_levels) {
> +	case 1:
> +		method = "SBL2";
> +		break;
> +	default:
> +		method = "SBLL";
> +		break;
>  	}

This is not necessary something actionable, but I am wondering about the
rationale of using a switch statement here given that there really are only
two options.  In my mind at least a simple "if" clause would be clearer and
easier to read (with or without the braces):

  if (use_alt_lcd_levels) {
          method = "SBL2";
  } else {
          method = "SBLL";
  }

Regards
  jonathan

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2 00/11] fujitsu-laptop: backlight cleanup Michał Kępień <kernel@kempniu.pl> - 2017-04-05 08:50 +0200
  [PATCH v2 11/11] platform/x86: fujitsu-laptop: remove redundant fields from struct fujitsu_bl Michał Kępień <kernel@kempniu.pl> - 2017-04-05 08:50 +0200
  [PATCH v2 10/11] platform/x86: fujitsu-laptop: account for backlight power when determining brightness Michał Kępień <kernel@kempniu.pl> - 2017-04-05 08:50 +0200
  [PATCH v2 07/11] platform/x86: fujitsu-laptop: make disable_brightness_adjust a boolean Michał Kępień <kernel@kempniu.pl> - 2017-04-05 08:50 +0200
  [PATCH v2 08/11] platform/x86: fujitsu-laptop: ignore errors when setting backlight power Michał Kępień <kernel@kempniu.pl> - 2017-04-05 09:00 +0200
  [PATCH v2 06/11] platform/x86: fujitsu-laptop: clean up use_alt_lcd_levels handling Michał Kępień <kernel@kempniu.pl> - 2017-04-05 09:00 +0200
  [PATCH v2 02/11] platform/x86: fujitsu-laptop: switch to a managed backlight device Michał Kępień <kernel@kempniu.pl> - 2017-04-05 09:00 +0200
  [PATCH v2 04/11] platform/x86: fujitsu-laptop: simplify set_lcd_level() Michał Kępień <kernel@kempniu.pl> - 2017-04-05 09:00 +0200
  [PATCH v2 05/11] platform/x86: fujitsu-laptop: sync brightness in set_lcd_level() Michał Kępień <kernel@kempniu.pl> - 2017-04-05 09:00 +0200
  [PATCH v2 01/11] platform/x86: fujitsu-laptop: only handle backlight when appropriate Michał Kępień <kernel@kempniu.pl> - 2017-04-05 09:00 +0200
  [PATCH v2 09/11] platform/x86: fujitsu-laptop: do not log set_lcd_level() failures in bl_update_status() Michał Kępień <kernel@kempniu.pl> - 2017-04-05 09:00 +0200
  [PATCH v2 03/11] platform/x86: fujitsu-laptop: merge set_lcd_level_alt() into set_lcd_level() Michał Kępień <kernel@kempniu.pl> - 2017-04-05 09:00 +0200
    Re: [PATCH v2 03/11] platform/x86: fujitsu-laptop: merge  set_lcd_level_alt() into set_lcd_level() Jonathan Woithe <jwoithe@just42.net> - 2017-04-07 14:00 +0200
      Re: [PATCH v2 03/11] platform/x86: fujitsu-laptop: merge  set_lcd_level_alt() into set_lcd_level() Jonathan Woithe <jwoithe@just42.net> - 2017-04-07 14:10 +0200
  Re: [PATCH v2 00/11] fujitsu-laptop: backlight cleanup Darren Hart <dvhart@infradead.org> - 2017-04-05 17:40 +0200
    Re: [PATCH v2 00/11] fujitsu-laptop: backlight cleanup Michał Kępień <kernel@kempniu.pl> - 2017-04-05 22:00 +0200
      Re: [PATCH v2 00/11] fujitsu-laptop: backlight cleanup Jonathan Woithe <jwoithe@just42.net> - 2017-04-06 02:50 +0200
        Re: [PATCH v2 00/11] fujitsu-laptop: backlight cleanup Darren Hart <dvhart@infradead.org> - 2017-04-06 05:10 +0200
          Re: [PATCH v2 00/11] fujitsu-laptop: backlight cleanup Jonathan Woithe <jwoithe@just42.net> - 2017-04-07 14:20 +0200
            Re: [PATCH v2 00/11] fujitsu-laptop: backlight cleanup Darren Hart <dvhart@infradead.org> - 2017-04-07 20:00 +0200

csiph-web