Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1598805
| From | Eric Biggers <ebiggers3@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v3] statx: optimize copy of struct statx to userspace |
| Date | 2017-03-13 02:10 +0100 |
| Message-ID | <tkmEN-1aC-1@gated-at.bofh.it> (permalink) |
| References | <tk5kC-64h-3@gated-at.bofh.it> <tk7Pr-7PH-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi David, On Sun, Mar 12, 2017 at 09:11:53AM +0000, David Howells wrote: > Eric Biggers <ebiggers3@gmail.com> wrote: > > > +static int cp_statx(const struct kstat *stat, struct statx __user *buffer) > > ... > > + struct statx tmp; > > This function needs to be "noinline" as tmp is big. > > > - return statx_set_result(&stat, buffer); > > + > > + return cp_statx(&stat, buffer); > > Can you leave it as statx_set_result rather than renaming it to cp_statx? > > David I agree with using 'noinline'. But I think the name "cp_statx()" is better because it's consistent with the existing functions in the file: cp_old_stat() cp_new_stat() cp_new_stat64() - Eric
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v3] statx: optimize copy of struct statx to userspace Eric Biggers <ebiggers3@gmail.com> - 2017-03-12 07:40 +0100
Re: [PATCH v3] statx: optimize copy of struct statx to userspace David Howells <dhowells@redhat.com> - 2017-03-12 10:20 +0100
Re: [PATCH v3] statx: optimize copy of struct statx to userspace Eric Biggers <ebiggers3@gmail.com> - 2017-03-13 02:10 +0100
csiph-web