Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1594369

Re: [PATCH] blk: improve order of bio handling in generic_make_request()

From Pavel Machek <pavel@ucw.cz>
Newsgroups linux.kernel
Subject Re: [PATCH] blk: improve order of bio handling in generic_make_request()
Date 2017-03-07 16:50 +0100
Message-ID <tipx7-18u-9@gated-at.bofh.it> (permalink)
References <tgNNg-4Jz-3@gated-at.bofh.it> <tgRQS-7Cb-7@gated-at.bofh.it> <thSKR-2BN-13@gated-at.bofh.it> <thXrd-6fC-53@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


[Multipart message — attachments visible in raw view] - view raw

On Mon 2017-03-06 10:43:59, Jack Wang wrote:
> 
> 
> On 06.03.2017 05:40, NeilBrown wrote:
> > On Fri, Mar 03 2017, Jack Wang wrote:
> >>
> >> Thanks Neil for pushing the fix.
> >>
> >> We can optimize generic_make_request a little bit:
> >> - assign bio_list struct hold directly instead init and merge
> >> - remove duplicate code
> >>
> >> I think better to squash into your fix.
> > 
> > Hi Jack,
> >  I don't object to your changes, but I'd like to see a response from
> >  Jens first.
> >  My preference would be to get the original patch in, then other changes
> >  that build on it, such as this one, can be added.  Until the core
> >  changes lands, any other work is pointless.
> > 
> >  Of course if Jens wants a this merged before he'll apply it, I'll
> >  happily do that.
> > 
> > Thanks,
> > NeilBrown
> 
> Hi Neil,
> 
> Totally agree, let's wait for Jens's decision.
> 
> Hi Jens,
> 
> Please consider this fix also for stable 4.3+ 

Stable? We don't put this into stable, with exception of minimal fixes
for real bugs...
									Pavel
-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH] blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-03 06:20 +0100
  Re: [PATCH] blk: improve order of bio handling in  generic_make_request() Jack Wang <jinpu.wang@profitbricks.com> - 2017-03-03 10:40 +0100
    Re: [PATCH] blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-06 05:50 +0100
      Re: [PATCH] blk: improve order of bio handling in  generic_make_request() Jack Wang <jinpu.wang@profitbricks.com> - 2017-03-06 10:50 +0100
        Re: [PATCH] blk: improve order of bio handling in  generic_make_request() Pavel Machek <pavel@ucw.cz> - 2017-03-07 16:50 +0100
          Re: [PATCH] blk: improve order of bio handling in  generic_make_request() Jens Axboe <axboe@kernel.dk> - 2017-03-07 17:30 +0100
          Re: [PATCH] blk: improve order of bio handling in  generic_make_request() Jack Wang <jinpu.wang@profitbricks.com> - 2017-03-07 20:00 +0100
      Re: [PATCH] blk: improve order of bio handling in  generic_make_request() Jens Axboe <axboe@kernel.dk> - 2017-03-07 03:10 +0100
        Re: [PATCH] blk: improve order of bio handling in  generic_make_request() Jack Wang <jinpu.wang@profitbricks.com> - 2017-03-07 10:00 +0100
          Re: blk: improve order of bio handling in generic_make_request() Jens Axboe <axboe@kernel.dk> - 2017-03-07 18:20 +0100
            Re: blk: improve order of bio handling in generic_make_request() Mike Snitzer <snitzer@redhat.com> - 2017-03-07 18:40 +0100
              Re: blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-07 22:20 +0100
                Re: blk: improve order of bio handling in generic_make_request() Mike Snitzer <snitzer@redhat.com> - 2017-03-08 02:00 +0100
                Re: blk: improve order of bio handling in generic_make_request() Mikulas Patocka <mpatocka@redhat.com> - 2017-03-08 18:00 +0100
                Re: blk: improve order of bio handling in generic_make_request() Lars Ellenberg <lars.ellenberg@linbit.com> - 2017-03-08 18:40 +0100
                Re: blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-09 07:10 +0100
          Re: blk: improve order of bio handling in generic_make_request() Mike Snitzer <snitzer@redhat.com> - 2017-03-07 18:50 +0100
            Re: blk: improve order of bio handling in generic_make_request() Lars Ellenberg <lars.ellenberg@linbit.com> - 2017-03-08 14:00 +0100
        [PATCH v2] blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-07 21:50 +0100
          Re: [PATCH v2] blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-10 05:40 +0100
            [PATCH 5/5] block_dev: make blkdev_dio_pool a non-rescuing bioset NeilBrown <neilb@suse.com> - 2017-03-10 05:40 +0100
            Re: [PATCH v2] blk: improve order of bio handling in  generic_make_request() Jens Axboe <axboe@kernel.dk> - 2017-03-10 05:40 +0100
              Re: [PATCH v2] blk: improve order of bio handling in  generic_make_request() Jens Axboe <axboe@kernel.dk> - 2017-03-10 05:50 +0100
              Re: [PATCH v2] blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-10 06:20 +0100
                Re: [PATCH v2] blk: improve order of bio handling in generic_make_request() Lars Ellenberg <lars.ellenberg@linbit.com> - 2017-03-10 13:40 +0100
                Re: [PATCH v2] blk: improve order of bio handling in  generic_make_request() Mike Snitzer <snitzer@redhat.com> - 2017-03-10 15:40 +0100
                Re: [PATCH v2] blk: improve order of bio handling in  generic_make_request() Mikulas Patocka <mpatocka@redhat.com> - 2017-03-10 16:00 +0100
                Re: [PATCH v2] blk: improve order of bio handling in  generic_make_request() Jack Wang <jinpu.wang@profitbricks.com> - 2017-03-10 16:20 +0100
                Re: [PATCH v2] blk: improve order of bio handling in  generic_make_request() Mike Snitzer <snitzer@redhat.com> - 2017-03-10 16:40 +0100
                Re: [PATCH v2] blk: improve order of bio handling in  generic_make_request() Lars Ellenberg <lars.ellenberg@linbit.com> - 2017-03-10 20:00 +0100
                Re: [PATCH v2] blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-11 01:50 +0100
            [PATCH 1/5 v3] blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-10 05:40 +0100
            [PATCH 3/5] blk: make the bioset rescue_workqueue optional. NeilBrown <neilb@suse.com> - 2017-03-10 05:40 +0100
            [PATCH 4/5] blk: use non-rescuing bioset for q->bio_split. NeilBrown <neilb@suse.com> - 2017-03-10 05:40 +0100
            [PATCH 2/5] blk: remove bio_set arg from blk_queue_split() NeilBrown <neilb@suse.com> - 2017-03-10 05:40 +0100

csiph-web