Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1593127
| From | Jack Wang <jinpu.wang@profitbricks.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] blk: improve order of bio handling in generic_make_request() |
| Date | 2017-03-06 10:50 +0100 |
| Message-ID | <thXrd-6fC-53@gated-at.bofh.it> (permalink) |
| References | <tgNNg-4Jz-3@gated-at.bofh.it> <tgRQS-7Cb-7@gated-at.bofh.it> <thSKR-2BN-13@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 06.03.2017 05:40, NeilBrown wrote:
> On Fri, Mar 03 2017, Jack Wang wrote:
>>
>> Thanks Neil for pushing the fix.
>>
>> We can optimize generic_make_request a little bit:
>> - assign bio_list struct hold directly instead init and merge
>> - remove duplicate code
>>
>> I think better to squash into your fix.
>
> Hi Jack,
> I don't object to your changes, but I'd like to see a response from
> Jens first.
> My preference would be to get the original patch in, then other changes
> that build on it, such as this one, can be added. Until the core
> changes lands, any other work is pointless.
>
> Of course if Jens wants a this merged before he'll apply it, I'll
> happily do that.
>
> Thanks,
> NeilBrown
Hi Neil,
Totally agree, let's wait for Jens's decision.
Hi Jens,
Please consider this fix also for stable 4.3+
Thanks,
Jack Wang
>
>
>
>> ---
>> block/blk-core.c | 9 ++-------
>> 1 file changed, 2 insertions(+), 7 deletions(-)
>>
>> diff --git a/block/blk-core.c b/block/blk-core.c
>> index 3bc7202..b29b7e5 100644
>> --- a/block/blk-core.c
>> +++ b/block/blk-core.c
>> @@ -2147,8 +2147,7 @@ blk_qc_t generic_make_request(struct bio *bio)
>> struct bio_list lower, same, hold;
>>
>> /* Create a fresh bio_list for all subordinate requests */
>> - bio_list_init(&hold);
>> - bio_list_merge(&hold, &bio_list_on_stack);
>> + hold = bio_list_on_stack;
>> bio_list_init(&bio_list_on_stack);
>>
>> ret = q->make_request_fn(q, bio);
>> @@ -2168,14 +2167,10 @@ blk_qc_t generic_make_request(struct bio *bio)
>> bio_list_merge(&bio_list_on_stack, &lower);
>> bio_list_merge(&bio_list_on_stack, &same);
>> bio_list_merge(&bio_list_on_stack, &hold);
>> -
>> - bio = bio_list_pop(current->bio_list);
>> } else {
>> - struct bio *bio_next = bio_list_pop(current->bio_list);
>> -
>> bio_io_error(bio);
>> - bio = bio_next;
>> }
>> + bio = bio_list_pop(current->bio_list);
>> } while (bio);
>> current->bio_list = NULL; /* deactivate */
>>
>> --
>>
>> Regards,
>> Jack
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-03 06:20 +0100
Re: [PATCH] blk: improve order of bio handling in generic_make_request() Jack Wang <jinpu.wang@profitbricks.com> - 2017-03-03 10:40 +0100
Re: [PATCH] blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-06 05:50 +0100
Re: [PATCH] blk: improve order of bio handling in generic_make_request() Jack Wang <jinpu.wang@profitbricks.com> - 2017-03-06 10:50 +0100
Re: [PATCH] blk: improve order of bio handling in generic_make_request() Pavel Machek <pavel@ucw.cz> - 2017-03-07 16:50 +0100
Re: [PATCH] blk: improve order of bio handling in generic_make_request() Jens Axboe <axboe@kernel.dk> - 2017-03-07 17:30 +0100
Re: [PATCH] blk: improve order of bio handling in generic_make_request() Jack Wang <jinpu.wang@profitbricks.com> - 2017-03-07 20:00 +0100
Re: [PATCH] blk: improve order of bio handling in generic_make_request() Jens Axboe <axboe@kernel.dk> - 2017-03-07 03:10 +0100
Re: [PATCH] blk: improve order of bio handling in generic_make_request() Jack Wang <jinpu.wang@profitbricks.com> - 2017-03-07 10:00 +0100
Re: blk: improve order of bio handling in generic_make_request() Jens Axboe <axboe@kernel.dk> - 2017-03-07 18:20 +0100
Re: blk: improve order of bio handling in generic_make_request() Mike Snitzer <snitzer@redhat.com> - 2017-03-07 18:40 +0100
Re: blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-07 22:20 +0100
Re: blk: improve order of bio handling in generic_make_request() Mike Snitzer <snitzer@redhat.com> - 2017-03-08 02:00 +0100
Re: blk: improve order of bio handling in generic_make_request() Mikulas Patocka <mpatocka@redhat.com> - 2017-03-08 18:00 +0100
Re: blk: improve order of bio handling in generic_make_request() Lars Ellenberg <lars.ellenberg@linbit.com> - 2017-03-08 18:40 +0100
Re: blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-09 07:10 +0100
Re: blk: improve order of bio handling in generic_make_request() Mike Snitzer <snitzer@redhat.com> - 2017-03-07 18:50 +0100
Re: blk: improve order of bio handling in generic_make_request() Lars Ellenberg <lars.ellenberg@linbit.com> - 2017-03-08 14:00 +0100
[PATCH v2] blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-07 21:50 +0100
Re: [PATCH v2] blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-10 05:40 +0100
[PATCH 5/5] block_dev: make blkdev_dio_pool a non-rescuing bioset NeilBrown <neilb@suse.com> - 2017-03-10 05:40 +0100
Re: [PATCH v2] blk: improve order of bio handling in generic_make_request() Jens Axboe <axboe@kernel.dk> - 2017-03-10 05:40 +0100
Re: [PATCH v2] blk: improve order of bio handling in generic_make_request() Jens Axboe <axboe@kernel.dk> - 2017-03-10 05:50 +0100
Re: [PATCH v2] blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-10 06:20 +0100
Re: [PATCH v2] blk: improve order of bio handling in generic_make_request() Lars Ellenberg <lars.ellenberg@linbit.com> - 2017-03-10 13:40 +0100
Re: [PATCH v2] blk: improve order of bio handling in generic_make_request() Mike Snitzer <snitzer@redhat.com> - 2017-03-10 15:40 +0100
Re: [PATCH v2] blk: improve order of bio handling in generic_make_request() Mikulas Patocka <mpatocka@redhat.com> - 2017-03-10 16:00 +0100
Re: [PATCH v2] blk: improve order of bio handling in generic_make_request() Jack Wang <jinpu.wang@profitbricks.com> - 2017-03-10 16:20 +0100
Re: [PATCH v2] blk: improve order of bio handling in generic_make_request() Mike Snitzer <snitzer@redhat.com> - 2017-03-10 16:40 +0100
Re: [PATCH v2] blk: improve order of bio handling in generic_make_request() Lars Ellenberg <lars.ellenberg@linbit.com> - 2017-03-10 20:00 +0100
Re: [PATCH v2] blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-11 01:50 +0100
[PATCH 1/5 v3] blk: improve order of bio handling in generic_make_request() NeilBrown <neilb@suse.com> - 2017-03-10 05:40 +0100
[PATCH 3/5] blk: make the bioset rescue_workqueue optional. NeilBrown <neilb@suse.com> - 2017-03-10 05:40 +0100
[PATCH 4/5] blk: use non-rescuing bioset for q->bio_split. NeilBrown <neilb@suse.com> - 2017-03-10 05:40 +0100
[PATCH 2/5] blk: remove bio_set arg from blk_queue_split() NeilBrown <neilb@suse.com> - 2017-03-10 05:40 +0100
csiph-web