Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1594052
| From | Kishon Vijay Abraham I <kishon@ti.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v2 0/7] PCI: dwc: miscellaneous fixes and cleanups |
| Date | 2017-03-07 11:00 +0100 |
| Message-ID | <tik4p-5CJ-1@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
This should be the final set of cleanups/fixes before endpoint support can be merged. Keerthy's patch is a general fix in dra7xx driver and is not directly related to endpoint mode. This series was previously sent with a different cover letter $subject [1] Changes from v1: *) included a patch to rename _unroll() to _ob_unroll() as similar thing has to be done for inbound window in the case of EP mode. *) used 'size_t' instead of 'int' for specifying the size in read_dbi/write_dbi function arguments. *) Populate cpu_addr_fixup ops for artpec6 as suggested by Niklas This series is based on 4.11-rc1 [1] -> https://lkml.org/lkml/2017/2/16/270 Keerthy (1): PCI: dwc: dra7xx: Push request_irq call to the bottom of probe Kishon Vijay Abraham I (6): PCI: dwc: designware: Add new *ops* for cpu addr fixup PCI: dwc: dra7xx: Populate cpu_addr_fixup ops PCI: dwc: artpec6: Populate cpu_addr_fixup ops PCI: dwc: all: Modify dbi accessors to take dbi_base as argument PCI: dwc: all: Modify dbi accessors to access data of 4/2/1 bytes PCI: dwc: designware: Modify _unroll() to _ob_unroll() drivers/pci/dwc/Kconfig | 18 ++--- drivers/pci/dwc/pci-dra7xx.c | 35 +++++---- drivers/pci/dwc/pci-exynos.c | 14 ++-- drivers/pci/dwc/pci-imx6.c | 62 +++++++++------- drivers/pci/dwc/pci-keystone-dw.c | 16 ++-- drivers/pci/dwc/pcie-armada8k.c | 39 +++++----- drivers/pci/dwc/pcie-artpec6.c | 22 ++++-- drivers/pci/dwc/pcie-designware-host.c | 20 ++--- drivers/pci/dwc/pcie-designware.c | 127 ++++++++++++++++++++------------ drivers/pci/dwc/pcie-designware.h | 13 +++- drivers/pci/dwc/pcie-hisi.c | 17 +++-- 11 files changed, 226 insertions(+), 157 deletions(-) -- 1.7.9.5
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH v2 0/7] PCI: dwc: miscellaneous fixes and cleanups Kishon Vijay Abraham I <kishon@ti.com> - 2017-03-07 11:00 +0100
[PATCH v2 1/7] PCI: dwc: designware: Add new *ops* for cpu addr fixup Kishon Vijay Abraham I <kishon@ti.com> - 2017-03-07 11:00 +0100
Re: [PATCH v2 1/7] PCI: dwc: designware: Add new *ops* for cpu addr fixup Joao Pinto <Joao.Pinto@synopsys.com> - 2017-03-07 12:20 +0100
[PATCH v2 4/7] PCI: dwc: all: Modify dbi accessors to take dbi_base as argument Kishon Vijay Abraham I <kishon@ti.com> - 2017-03-07 11:00 +0100
Re: [PATCH v2 4/7] PCI: dwc: all: Modify dbi accessors to take dbi_base as argument Joao Pinto <Joao.Pinto@synopsys.com> - 2017-03-07 13:30 +0100
[PATCH v2 2/7] PCI: dwc: dra7xx: Populate cpu_addr_fixup ops Kishon Vijay Abraham I <kishon@ti.com> - 2017-03-07 11:00 +0100
Re: [PATCH v2 2/7] PCI: dwc: dra7xx: Populate cpu_addr_fixup ops Joao Pinto <Joao.Pinto@synopsys.com> - 2017-03-07 12:30 +0100
[PATCH v2 3/7] PCI: dwc: artpec6: Populate cpu_addr_fixup ops Kishon Vijay Abraham I <kishon@ti.com> - 2017-03-07 11:00 +0100
Re: [PATCH v2 3/7] PCI: dwc: artpec6: Populate cpu_addr_fixup ops Joao Pinto <Joao.Pinto@synopsys.com> - 2017-03-07 12:30 +0100
[PATCH v2 6/7] PCI: dwc: designware: Modify _unroll() to _ob_unroll() Kishon Vijay Abraham I <kishon@ti.com> - 2017-03-07 11:10 +0100
Re: [PATCH v2 5/7] PCI: dwc: all: Modify dbi accessors to access data of 4/2/1 bytes Kishon Vijay Abraham I <kishon@ti.com> - 2017-03-07 12:30 +0100
Re: [PATCH v2 5/7] PCI: dwc: all: Modify dbi accessors to access data of 4/2/1 bytes Joao Pinto <Joao.Pinto@synopsys.com> - 2017-03-07 15:30 +0100
[PATCH v2 5/7] PCI: dwc: all: Modify dbi accessors to access data of 4/2/1 bytes Kishon Vijay Abraham I <kishon@ti.com> - 2017-03-08 19:40 +0100
csiph-web