Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1589293

Re: [PATCH v3 3/6] ARM: davinci: da8xx: add pdata-quirks for VPIF capture

From Sekhar Nori <nsekhar@ti.com>
Newsgroups linux.kernel
Subject Re: [PATCH v3 3/6] ARM: davinci: da8xx: add pdata-quirks for VPIF capture
Date 2017-02-28 10:00 +0100
Message-ID <tfLNA-22y-11@gated-at.bofh.it> (permalink)
References <tdFVT-2TB-1@gated-at.bofh.it> <tdFVU-2TB-23@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Wednesday 22 February 2017 07:43 PM, Bartosz Golaszewski wrote:
> From: Kevin Hilman <khilman@baylibre.com>
> 
> For da8xx DT platforms, use pdata-quirks to add legacy platform data for
> vpif_capture driver.
> 
> Passing legacy platform_data is required until the V4L2 framework, and
> subdevice drivers (such as the tvp514x) grow a way of selecting input
> and output routing  (c.f. V4L2 s_routing API)
> 
> Signed-off-by: Kevin Hilman <khilman@baylibre.com>
> [Bartosz: removed unnecessary #ifdefs]
> Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
> ---
>  arch/arm/mach-davinci/da8xx-dt.c     |   1 +
>  arch/arm/mach-davinci/pdata-quirks.c | 104 +++++++++++++++++++++++++++++++++++
>  2 files changed, 105 insertions(+)
> 
> diff --git a/arch/arm/mach-davinci/da8xx-dt.c b/arch/arm/mach-davinci/da8xx-dt.c
> index e3cef50..5699ce3 100644
> --- a/arch/arm/mach-davinci/da8xx-dt.c
> +++ b/arch/arm/mach-davinci/da8xx-dt.c
> @@ -53,6 +53,7 @@ static struct of_dev_auxdata da850_auxdata_lookup[] __initdata = {
>  	OF_DEV_AUXDATA("ti,da830-musb", 0x01e00000, "musb-da8xx", NULL),
>  	OF_DEV_AUXDATA("ti,da830-usb-phy", 0x01c1417c, "da8xx-usb-phy", NULL),
>  	OF_DEV_AUXDATA("ti,da850-ahci", 0x01e18000, "ahci_da850", NULL),
> +	OF_DEV_AUXDATA("ti,da850-vpif", 0x01e17000, "vpif", NULL),

You don't talk about adding OF_DEV_AUXDATA in patch description. Can you
either add description for this change or spin it into a separate patch?
I prefer the later, but will take it either way.

> +static void __init da850_vpif_legacy_init(void)
> +{
> +	int ret;
> +
> +	/* LCDK doesn't have the 2nd TVP514x on CH1 */
> +	if (of_machine_is_compatible("ti,da850-lcdk"))
> +		da850_vpif_capture_config.subdev_count = 1;

Since you anyway register quirk for lcdk separately, you can as well
create da850_lcdk_vpif_capture_init() which sets subdev_count to 1
unconditionally.

Also, since you rename the function to add "capture" down the series,
you can as well have that name from the start. It will make the later
patches easier to read.

Thanks,
Sekhar

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v3 0/6] ARM: davinci: vpif capture & display support Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2017-02-22 15:20 +0100
  [PATCH v3 1/6] ARM: davinci: da8xx: allow having multiple pdata-quirks Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2017-02-22 15:20 +0100
    Re: [PATCH v3 1/6] ARM: davinci: da8xx: allow having multiple pdata-quirks Kevin Hilman <khilman@baylibre.com> - 2017-02-28 19:10 +0100
  [PATCH v3 4/6] ARM: da850-evm: add a fixed regulator for the UI board IO expander Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2017-02-22 15:20 +0100
  [PATCH v3 5/6] ARM: davinci: add pdata-quirks for da850-evm vpif display Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2017-02-22 15:20 +0100
  [PATCH v3 2/6] ARM: davinci: board-da850-evm: add I2C ID for VPIF Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2017-02-22 15:20 +0100
  [PATCH v3 3/6] ARM: davinci: da8xx: add pdata-quirks for VPIF capture Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2017-02-22 15:20 +0100
    Re: [PATCH v3 3/6] ARM: davinci: da8xx: add pdata-quirks for VPIF  capture Sekhar Nori <nsekhar@ti.com> - 2017-02-28 10:00 +0100
  [PATCH v3 6/6] ARM: davinci: add enable GPIOs for vpif capture to pdata-quirks Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2017-02-22 15:20 +0100
    Re: [PATCH v3 6/6] ARM: davinci: add enable GPIOs for vpif capture to  pdata-quirks Sekhar Nori <nsekhar@ti.com> - 2017-02-28 10:10 +0100
      Re: [PATCH v3 6/6] ARM: davinci: add enable GPIOs for vpif capture to pdata-quirks Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2017-02-28 11:00 +0100

csiph-web