Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1660830

Re: [PATCH] x86/ldt: Rename ldr_struct.size to .n_entries

From Ingo Molnar <mingo@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH] x86/ldt: Rename ldr_struct.size to .n_entries
Date 2017-06-08 09:30 +0200
Message-ID <tQ03f-1dY-5@gated-at.bofh.it> (permalink)
References <tPqCv-3oY-49@gated-at.bofh.it> <tPv98-6pY-17@gated-at.bofh.it> <tPGnU-5m0-15@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


* Borislav Petkov <bp@alien8.de> wrote:

> On Tue, Jun 06, 2017 at 03:20:22PM -0700, Andy Lutomirski wrote:
> > In the subject: ldt_struct, perhaps?
> 
> Right. Committer, pls fix. :-)

Fixed. I also renamed 'n_entries' to 'nr_entries', which is the canonical form:

  triton:~/tip> git grep -w n_entries | wc -l
  191

  triton:~/tip> git grep -w nr_entries | wc -l
  743

If we do a rename, we should do it right, painted bright red! ;-)


Thanks,

	Ingo

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

Re: [PATCH] x86/ldt: Rename ldr_struct.size to .n_entries Ingo Molnar <mingo@kernel.org> - 2017-06-08 09:30 +0200

csiph-web