Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1659261

Re: [PATCH] x86/ldt: Rename ldr_struct.size to .n_entries

From Andy Lutomirski <luto@amacapital.net>
Newsgroups linux.kernel
Subject Re: [PATCH] x86/ldt: Rename ldr_struct.size to .n_entries
Date 2017-06-07 00:30 +0200
Message-ID <tPv98-6pY-17@gated-at.bofh.it> (permalink)
References <tPqCv-3oY-49@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, Jun 6, 2017 at 10:31 AM, Borislav Petkov <bp@alien8.de> wrote:
> From: Borislav Petkov <bp@suse.de>
>
> ... because this is exactly what it is: the number of entries in the
> LDT. Calling it "size" is simply confusing and it is actually begging
> to be called "n_entries" or somesuch, especially if you see constructs
> like:

In the subject: ldt_struct, perhaps?

Otherwise looks good.

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH] x86/ldt: Rename ldr_struct.size to .n_entries Borislav Petkov <bp@alien8.de> - 2017-06-06 19:40 +0200
  Re: [PATCH] x86/ldt: Rename ldr_struct.size to .n_entries Andy Lutomirski <luto@amacapital.net> - 2017-06-07 00:30 +0200
    Re: [PATCH] x86/ldt: Rename ldr_struct.size to .n_entries Borislav Petkov <bp@alien8.de> - 2017-06-07 12:30 +0200

csiph-web