Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1660639
| From | "Jason A. Donenfeld" <Jason@zx2c4.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v4 04/13] security/keys: ensure RNG is seeded before use |
| Date | 2017-06-08 03:00 +0200 |
| Message-ID | <tPTXP-5yb-7@gated-at.bofh.it> (permalink) |
| References | <tPqM9-3tE-3@gated-at.bofh.it> <tPqMa-3tE-35@gated-at.bofh.it> <tPTEu-5rT-17@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thu, Jun 8, 2017 at 2:31 AM, Theodore Ts'o <tytso@mit.edu> wrote: > I'm guessing you changed key_alloc_serial() to return an int back when > you were thinking that you might use get_random_bytes_wait(), which > could return -ERESTARTSYS. > > Now that you're not doing this, but using get_random_u32() instead, > there's no point to change the function signature of > key_alloc_serial() and add an error check in key_alloc() that will > never fail, right? That's just adding a dead code path. Which the > compiler can probably optimize away, but why make the code slightly > harder to read than necessasry? Good catch, and thanks for reading these so thoroughly that you caught the churn artifacts. Do you want me to clean this up and resubmit, or are you planning on adjusting it in the dev branch?
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Re: [PATCH v4 04/13] security/keys: ensure RNG is seeded before use Theodore Ts'o <tytso@mit.edu> - 2017-06-08 02:40 +0200
Re: [PATCH v4 04/13] security/keys: ensure RNG is seeded before use "Jason A. Donenfeld" <Jason@zx2c4.com> - 2017-06-08 03:00 +0200
Re: [PATCH v4 04/13] security/keys: ensure RNG is seeded before use "Jason A. Donenfeld" <Jason@zx2c4.com> - 2017-06-08 03:10 +0200
csiph-web