Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1657629
| From | Stephen Rothwell <sfr@canb.auug.org.au> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: new tree for linux-next: uuid |
| Date | 2017-06-05 16:30 +0200 |
| Message-ID | <tP1b4-41e-11@gated-at.bofh.it> (permalink) |
| References | <tOKad-1to-9@gated-at.bofh.it> <tONB7-3oN-11@gated-at.bofh.it> <tOVfk-kl-13@gated-at.bofh.it> <tP0RI-3Up-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi Andy, On Mon, 05 Jun 2017 17:06:45 +0300 Andy Shevchenko <andriy.shevchenko@linux.intel.com> wrote: > > On Mon, 2017-06-05 at 10:07 +0200, Christoph Hellwig wrote: > > Meh, thanks. This has been throught the buildbot countless times > > without a report. But I guess a less generic name might be a good > > idea to start with. > > > > Andy: do you think UUID_INIT/GUID_INIT make sense to your? > > or _INITIALIZER? > > I'm a bit out of context. Where this will be used? include/uapi/linux/uuid.h (after the uuid lib changes) contains a definition of the macro GUID() which is probably a bit generic a name for a uapi include file. It also clashes with a couple of other uses of that macro name already in the kernel (one of which produced several warnings in linux-next today). It produces an initializer for a guid_t (structure). -- Cheers, Stephen Rothwell
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
new tree for linux-next: uuid Christoph Hellwig <hch@lst.de> - 2017-06-04 22:20 +0200
Re: new tree for linux-next: uuid Stephen Rothwell <sfr@canb.auug.org.au> - 2017-06-05 02:00 +0200
Re: new tree for linux-next: uuid Christoph Hellwig <hch@lst.de> - 2017-06-05 10:10 +0200
Re: new tree for linux-next: uuid Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2017-06-05 16:10 +0200
Re: new tree for linux-next: uuid Stephen Rothwell <sfr@canb.auug.org.au> - 2017-06-05 16:30 +0200
Re: new tree for linux-next: uuid Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2017-06-05 16:50 +0200
Re: new tree for linux-next: uuid Christoph Hellwig <hch@lst.de> - 2017-06-05 17:00 +0200
csiph-web