Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1657647
| From | Christoph Hellwig <hch@lst.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: new tree for linux-next: uuid |
| Date | 2017-06-05 17:00 +0200 |
| Message-ID | <tP1E5-4e8-5@gated-at.bofh.it> (permalink) |
| References | (1 earlier) <tONB7-3oN-11@gated-at.bofh.it> <tOVfk-kl-13@gated-at.bofh.it> <tP0RI-3Up-11@gated-at.bofh.it> <tP1b4-41e-11@gated-at.bofh.it> <tP1uq-499-19@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, Jun 05, 2017 at 05:43:18PM +0300, Andy Shevchenko wrote: > On Tue, 2017-06-06 at 00:29 +1000, Stephen Rothwell wrote: > > Hi Andy, > > > > On Mon, 05 Jun 2017 17:06:45 +0300 Andy Shevchenko <andriy.shevchenko@ > > linux.intel.com> wrote: > > > > > > On Mon, 2017-06-05 at 10:07 +0200, Christoph Hellwig wrote: > > > > Meh, thanks. This has been throught the buildbot countless times > > > > without a report. But I guess a less generic name might be a good > > > > idea to start with. > > > > > > > > Andy: do you think UUID_INIT/GUID_INIT make sense to your? > > > > or _INITIALIZER? > > > > > > I'm a bit out of context. Where this will be used? > > > > include/uapi/linux/uuid.h (after the uuid lib changes) contains a > > definition of the macro GUID() which is probably a bit generic a name > > for a uapi include file. It also clashes with a couple of other uses > > of that macro name already in the kernel (one of which produced > > several > > warnings in linux-next today). > > > > It produces an initializer for a guid_t (structure). > > Just had read and finished answering to a warning. > In kernel users shouldn't really use so generic names, we may fix it. > > OTOH, for user space I dunno if need to export that at all. > If we need by some reason, shorter version looks better, GUID_INIT(), > UUID_INIT()... I'll fix it up without resending the whole series. I'll also apply your ACPI changes and if there is no major fallout we can declare the branch stable for drm in a few days.
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
new tree for linux-next: uuid Christoph Hellwig <hch@lst.de> - 2017-06-04 22:20 +0200
Re: new tree for linux-next: uuid Stephen Rothwell <sfr@canb.auug.org.au> - 2017-06-05 02:00 +0200
Re: new tree for linux-next: uuid Christoph Hellwig <hch@lst.de> - 2017-06-05 10:10 +0200
Re: new tree for linux-next: uuid Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2017-06-05 16:10 +0200
Re: new tree for linux-next: uuid Stephen Rothwell <sfr@canb.auug.org.au> - 2017-06-05 16:30 +0200
Re: new tree for linux-next: uuid Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2017-06-05 16:50 +0200
Re: new tree for linux-next: uuid Christoph Hellwig <hch@lst.de> - 2017-06-05 17:00 +0200
csiph-web