Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1655093
| From | Keith Busch <keith.busch@intel.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 6/8] nvme: provide UUID value to userspace |
| Date | 2017-06-01 14:40 +0200 |
| Message-ID | <tNxyp-2x0-1@gated-at.bofh.it> (permalink) |
| References | <tNwj0-1RP-9@gated-at.bofh.it> <tNwj0-1RP-15@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thu, Jun 01, 2017 at 01:17:48PM +0200, Johannes Thumshirn wrote: > Now that we have a way for getting the UUID from a target, provide it > to userspace as well. > > Unfortunately there is already a sysfs attribute called UUID which is > a misnomer as it holds the NGUID value. So instead of creating yet > another wrong name, create a new 'nguid' sysfs attribute for the > NGUID. For the UUID attribute add a check wheter the namespace has a > UUID assigned to it and return this or return the NGUID to maintain > backwards compatibility. This should give userspace a chance to catch > up. Sorry for the naming clash. Not sure why I didn't use the obvious name for this file in the first place. FWIW, tools should have been using the 'wwid' attribute, which returns either EUI64 or NGUID so a unique identifier can be gotten from a single file without checking for the existence of either. That should help not break backward compatibility, but I've no idea if anything actually relies on 'uuid' returning the NGUID.
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 0/8] Implement NVMe Namespace Descriptor Identification Johannes Thumshirn <jthumshirn@suse.de> - 2017-06-01 13:20 +0200
[PATCH v2 6/8] nvme: provide UUID value to userspace Johannes Thumshirn <jthumshirn@suse.de> - 2017-06-01 13:20 +0200
Re: [PATCH v2 6/8] nvme: provide UUID value to userspace Keith Busch <keith.busch@intel.com> - 2017-06-01 14:40 +0200
Re: [PATCH v2 6/8] nvme: provide UUID value to userspace Johannes Thumshirn <jthumshirn@suse.de> - 2017-06-01 15:10 +0200
[PATCH v2 7/8] nvmet: allow overriding the NVMe VS via configfs Johannes Thumshirn <jthumshirn@suse.de> - 2017-06-01 13:20 +0200
[PATCH v2 8/8] nvmet: use NVME_IDENTIFY_DATA_SIZE Johannes Thumshirn <jthumshirn@suse.de> - 2017-06-01 13:20 +0200
[PATCH v2 2/8] nvme: rename uuid to nguid in nvme_ns Johannes Thumshirn <jthumshirn@suse.de> - 2017-06-01 13:20 +0200
Re: [PATCH v2 2/8] nvme: rename uuid to nguid in nvme_ns Johannes Thumshirn <jthumshirn@suse.de> - 2017-06-07 15:50 +0200
Re: [PATCH v2 2/8] nvme: rename uuid to nguid in nvme_ns Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-06-07 15:50 +0200
[PATCH v2 1/8] nvme: introduce NVMe Namespace Identification Descriptor structures Johannes Thumshirn <jthumshirn@suse.de> - 2017-06-01 13:20 +0200
[PATCH v2 3/8] nvmet: implement namespace identify descriptor list Johannes Thumshirn <jthumshirn@suse.de> - 2017-06-01 13:20 +0200
[PATCH v2 5/8] nvme: get list of namespace descriptors Johannes Thumshirn <jthumshirn@suse.de> - 2017-06-01 13:30 +0200
csiph-web